Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got an older system that's resource challenged. I've disabled/removed gdm and kdm, and removed the splash screen by editing /etc/default/grub and running sudo update-grub.

GDM doesn't start, and I don't get the splash screen. However, I'm left with

Checking battery state [ OK ]

and I have to press ctrl+alt+F1 to get to the virtual terminal. How can I make the startup process end at tty0?

(I'm running Ubuntu 10.10)

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

X (window server) is starting with no window manager and you need to change your default runlevel but cannot find the /etc/inittab file and there is no appropriate runlevel to use anyway, right? If you do not want to use the cleanest method of installing 10.04/10.10 server, then just tell GDM not to even try on runlevel 3:

sudo -e /etc/init/gdm.conf

Change stop on runlevel [016] to stop on runlevel [0136]

Save. Now set the default runlevel:

sudo -e /etc/init/rc-sysinit.conf

Change env DEFAULT_RUNLEVEL=2 to env DEFAULT_RUNLEVEL=3

Save and reboot: sudo init 6

Success?

share|improve this answer
    
No dice... I'm assuming that it's actually setting the runlevel since runlevel outputs 3. I don't /think/ it's so much a problem with gdm, since I just went ahead and uninstalled it. –  Wayne Werner Jan 2 '12 at 6:23
    
After upgrading to 11.10 these changes were the same, and I changed /etc/init/kdm.conf to have start on runlevel [], and that fixed it. –  Wayne Werner Feb 9 '12 at 3:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.