Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i have kubuntu today after updating the muon package manager stuck at 64% so i closes it. and after that when i try to update or reinstall or install software the manger stuck. so how can i reinstall the muon package manger from terminal??

i try

sudo apt-get install muon

and i get this messege

Reading package lists... Done
Building dependency tree       
Reading state information... Done
muon is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libopencv-dev : Depends: libopencv-core-dev (= 2.3.1-4ppa1) but it is not going to be installed
                 Depends: libopencv-ml-dev (= 2.3.1-4ppa1) but it is not going to be installed
                 Depends: libopencv-imgproc-dev (= 2.3.1-4ppa1) but it is not going to be installed
                 Depends: libopencv-video-dev (= 2.3.1-4ppa1) but it is not going to be installed
                 Depends: libopencv-objdetect-dev (= 2.3.1-4ppa1) but it is not going to be installed
                 Depends: libopencv-gpu-dev (= 2.3.1-4ppa1) but it is not going to be installed
                 Depends: libopencv-highgui-dev (= 2.3.1-4ppa1) but it is not going to be installed
                 Depends: libopencv-calib3d-dev (= 2.3.1-4ppa1) but it is not going to be installed
                 Depends: libopencv-flann-dev (= 2.3.1-4ppa1) but it is not going to be installed
                 Depends: libopencv-features2d-dev (= 2.3.1-4ppa1) but it is not going to be installed
                 Depends: libopencv-legacy-dev (= 2.3.1-4ppa1) but it is not going to be installed
                 Depends: libopencv-contrib-dev (= 2.3.1-4ppa1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

so what to do, i need to reinstall it because it not working

~$ sudo dpkg --configure -a

dpkg: dependency problems prevent configuration of libopencv-dev:
 libopencv-dev depends on libopencv-core-dev (= 2.3.1-4ppa1); however:
  Package libopencv-core-dev is not installed.
 libopencv-dev depends on libopencv-ml-dev (= 2.3.1-4ppa1); however:
  Package libopencv-ml-dev is not installed.
 libopencv-dev depends on libopencv-imgproc-dev (= 2.3.1-4ppa1); however:
  Package libopencv-imgproc-dev is not installed.
 libopencv-dev depends on libopencv-video-dev (= 2.3.1-4ppa1); however:
  Package libopencv-video-dev is not installed.
 libopencv-dev depends on libopencv-objdetect-dev (= 2.3.1-4ppa1); however:
  Package libopencv-objdetect-dev is not installed.
 libopencv-dev depends on libopencv-gpu-dev (= 2.3.1-4ppa1); however:
  Package libopencv-gpu-dev is not installed.
 libopencv-dev depends on libopencv-highgui-dev (= 2.3.1-4ppa1); however:
  Package libopencv-highgui-dev is not installed.
 libopencv-dev depends on libopencv-calib3d-dev (= 2.3.1-4ppa1); however:
  Package libopencv-calib3d-dev is not installed.
 libopencv-dev depends on libopencv-flann-dev (= 2.3.1-4ppa1); however:
  Package libopencv-flann-dev is not installed.
 libopencv-dev depends on libopencv-features2d-dev (= 2.3.1-4ppa1); however:
  Package libopencv-features2d-dev is not installed.
 libopencv-dev depends on libopencv-legacy-dev (= 2.3.1-4ppa1); however:
  Package libopencv-legacy-dev is not installed.
 libopencv-dev depends on libopencv-contrib-dev (= 2.3.1-4ppa1); however:
  Package libopencv-contrib-dev is not installed.
dpkg: error processing libopencv-dev (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libopencv-dev

sudo apt-get install -f
sudo dpkg --configure -a

and still same problem... and i think getting this problem because of updating kubuntu today

share|improve this question
    
You have added some PPA or something that is causing this error, can you add some detail of what PPAs you've installed in your question? –  Jorge Castro Dec 31 '11 at 20:30
    
From the console did you try as mentioned above the sudo apt-get install -f? This should fi any missing dependencies that weren't installed. Also do you have PPA's configured or is this a stock install of Kubuntu? Muon is working fine on my current 11.10 and 12.04 installs of Kubuntu –  jjesse Dec 31 '11 at 21:59
add comment

4 Answers 4

I had this problem too.

Try to run these commands in the terminal ("Konsole"):

sudo apt-get install -f
sudo dpkg --configure -a
share|improve this answer
    
i try your answer : ~$ sudo dpkg --configure -a dpkg: dependency problems prevent configuration of libopencv-dev: libopencv-dev depends on libopencv-core-dev (= 2.3.1-4ppa1); however: Package libopencv-core-dev is not installed. libopencv-dev depends on libopencv-ml-dev (= 2.3.1-4ppa1); however: Package libopencv-ml-dev is not installed. libopencv-dev depends on libopencv-imgproc-dev (= 2.3.1-4ppa1); however: Package libopencv-imgproc-dev is not installed. libopencv-dev depends on libopencv-video-dev (= 2.3.1-4ppa1); however: Package libopencv-video-dev is not installed. libopencv-dev depends –  aseed Dec 31 '11 at 16:34
add comment

I had this too... the thing that got it working for me was to reinstall muon:

sudo apt-get purge muon
sudo apt-get install muon
share|improve this answer
add comment

I had and have this problem on brand new installs. To fix I added a newer version of Muon which is considered experimental. Please remember there are risks using unfamiliar PPA,s so read this if you have any questions. The PPA I used is ppa:echidnaman/qapt form here and this is where I got the information to use this fix.

share|improve this answer
add comment

Well, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

sudo apt-get -f install.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.