Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I got an GNU Emacs' problem, it can't work on X11 and crashes with a message "Font `Ubuntu Mono 13' is not defined" but it works fine without X, more Xemacs can run without problem, GNU Emacs is a version 23.2.1 and Xemacs is a [version 21.4.22; August 2010]

I saw the kotnik's post ont the 2011-11-21 22:45:49 and my problem is not related with these ttf-ubuntu-font-family as they are installed and it makes no help then i have no .emacs file and .emacs.d/ folder is empty.

The problem seems to be related with my user's profile cause it works fine with an other user's profile on the same system (the .emacs.d/ folder on that account is the same than mine.

share|improve this question
    
Try to start emacs with -q and with -Q if the problem goes away with -q it's your fault (your configuration under .emacs or .emacs.d) if the problem goes away with -Q then there is a problem with your system configuration or your X resources (something in .Xresources or /etc/) –  Daimrod Dec 31 '11 at 11:39
    
I tried this but none of them worked –  joanluc Jan 1 '12 at 23:12
add comment

3 Answers 3

I'm not an emacs expert but check you .emacs file the problem may be the combination of font and size is not supported. The line

(set-default-font "Monospace-12")

is in my .emacs file (in you home/user directory just in case you don't know) if you have no default font set try this one it works fine on my system.

share|improve this answer
1  
Just adding that line (set-default-font "Monospace-12") did'nt worked but that's the good way, i tried also launching emacs with the command : 'emacs -fn "Monospace-12"` and this one worked. Finally, i could anyway create a bashn alias to emacs with it. –  joanluc Jan 2 '12 at 20:46
add comment

Try adding following line into your ~/.Xdefaults file (if not exists create one with touch .Xdefaults):

   emacs.font:Monospace 12.

See man emacs for details.

share|improve this answer
add comment

The problem seems to stem from a users home directory that had been run under Ubuntu 11.10 or higher that set the gconf setting for /desktop/gnome/interface/monospace_font_name to Ubuntu Mono 13. Setting this to something that is available fixes the issue.

gconftool-2 -g /desktop/gnome/interface/monospace_font_name
Ubuntu Mono 13

Set it to Monospace-12 or whatever you would like:

gconftool-2 -t string -s /desktop/gnome/interface/monospace_font_name
Monospace-12

gconftool-2 -g /desktop/gnome/interface/monospace_font_name
Monospace-12
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.