Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to control the brightness of my notebook's screen using NVIDIA X Server but the changes only persist for a few seconds, then turns back to the default settings.

**I've already tried all i've found on the internet about this problem (xorg.conf, grub).

Also have tried changing the brightness from the terminal but it doesn't even recognize the device.

$ sudo setpci -s 00:02.0 F4.B=20
setpci: Warning: No devices selected for "F4.B=20".

This is very frustrating because my battery doesn't last as long as it does on windows.

My notebook is a Toshiba Satellite L750 with Geforce GT550.

$ lspci | grep nV
01:00.0 VGA compatible controller: nVidia Corporation Device 0dec (rev a1)
01:00.1 Audio device: nVidia Corporation GF108 High Definition Audio Controller (rev a1)
share|improve this question

1 Answer 1

up vote 0 down vote accepted

This solved the problem on a vaio laptop with nvidia card

http://ubuntuforums.org/showpost.php?p=11543948&postcount=40

share|improve this answer
    
Thanks a billion! It worked. –  flowerpower Dec 31 '11 at 10:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.