Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Can't seem to set VLC as the default video player. I have gone to System Settings -> System Info -> Default Applications, and changed "Video" to VLC media player.

However, all movies still open with Movie Player (Totem) by default. The video default application setting appears to have no effect. I have tried changing the setting and logging out/rebooting, it doesn't appear to work.

Is there some command line magic I can work on this?

share|improve this question

7 Answers 7

Go to System Settings/ System info/ Default Applications and set it there. Works in Ubuntu 11.10 Enjoy ;)

share|improve this answer
1  
Even though the poster states clearly that this doesn't work? I suspect that this only affect a certain extension - perhaps mp4. (S)He's trying to open a matroska (mkv) file and default applications appears to be ignoring that. –  Scaine Jan 24 '12 at 17:05
    
doesn't work for me –  Sirber Mar 17 '12 at 19:28
8  
In 13.04 it is in System Settings/Details/Default Applications –  ltn100 Jun 1 '13 at 9:30

Rightclick any video file, choose properties. Choose Open With and there you can select VLC and the option set as default (bottom right).

enter image description here

--

13.04 also has this option:

enter image description here

share|improve this answer
    
This step is to be done on all video filetypes. You can also replace /usr/share/applications/totem.desktop with /usr/share/applications/vlc.desktop to fool Ubuntu that VLC is Totem but I don't recommend this method. –  jcisio Dec 31 '11 at 9:42
    
No in 11.10 it is set for all video files iirc. –  Rinzwind Dec 31 '11 at 14:11
4  
If your screenshot is correct, the step you've done is just for "Matroska video". –  jcisio Jan 1 '12 at 4:51
2  
Set as default doesn't seem to be there in 13.04 –  ltn100 Jun 1 '13 at 9:32
2  
@Rinzwind - I didn't see it in a fresh install of 13.04 as well when trying to set VLC as the default for MP4's. I had to go into System Settings > Details > Default Applications as suggested by Pyri to change it. –  Nick Jan 2 at 3:53

In Ubuntu 12.10, go to

"System Settings" "Details" "Default Applications"

CLick on the "down arrow" for "Video"

Select "VLC Media Player"

Then close window.

share|improve this answer

Ubuntu 13.10, 14.04

Click on the gear icon in the top right corner then select the option About this computer. From that set Vlc media player as default application for opening videos.

enter image description here

enter image description here

share|improve this answer
    
hi! I set this (14.04) but nautilus has used totem (instead of vlc) yet. How can I set vlc as default for nautilus (and for gnome-disk-image-mounter too)? –  Regisz May 8 at 12:55
    
follow the first answer. –  Avinash Raj May 8 at 13:04
    
thx Avinash Raj, but I have problem with dvd-s not video files, so that answer does not help me (if I think well) –  Regisz May 8 at 13:07

Remove the totem video player via ubuntu software center. It appears with name "Video". This will make every video format use VLC automatically.

share|improve this answer

I managed to fix this by right click on the video file > Open With Other Applications > Right click on Banshee and click Forget association

I say Banshee, because I already uninstalled Totem in order to fix the issue.

share|improve this answer

For 12.04

In Ubuntu Tweak under File Type Manager you can change and set the default for all media types and their specific formats.

share|improve this answer
    
Worked nicely for me. Allows you to set the default for all extensions at once. –  Jobi Carter Jul 3 '13 at 15:01

protected by Community Apr 26 '13 at 23:30

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.