Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My friend has been running Ubuntu 11.10 for quite some time. Everything had been working fine.

The laptop shut down because of battery and when rebooted, the wireless lan hasn't been working with a message "Wireless is disabled by hardware switch". He has checked that the hardware switch is indeed on.

The output of rfkill list is as follows:

 0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
 1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
 2: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no

He even tried rfkill unblock all but rfkill list still showed Hard blocked: yes for phy0: Wireless LAN.

Following is the description of wireless interface returned by lshw:

 *-network DISABLED
   description: Wireless interface
   product: Centrino Wireless-N 1000
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:06:00.0
   logical name: wlan1
   version: 00
   serial: 74:e5:0b:0c:39:0e
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlagn driverversion=3.0.0-14-generic-pae firmware=128.50.3.1 build 13488 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
   resources: irq:42 memory:e8100000-e8101fff

Just for the info, my friend doesn't have Windows on his machine.

share|improve this question
    
can you please also include the rfkill list output? –  Paulius Šukys Dec 31 '11 at 9:03
    
I have edited the question to include the output of rfkill list. –  jitendra Dec 31 '11 at 17:11
1  
you said in the question that the "hardware switch is on" - what happens if you turn it "off" ? –  fossfreedom Dec 31 '11 at 17:11
    
Tried even that. In that case, rfkill list shows Hard Blocked: yes for all entries. –  jitendra Dec 31 '11 at 17:29
    
can you also show lsmod output? I believe it has something to do with wmi module –  Paulius Šukys Dec 31 '11 at 18:58

1 Answer 1

up vote 3 down vote accepted

My friend tried installing a new instance of Ubuntu but the problem persisted.

He, then, installed Windows along with the drivers. He activated wireless using key-combination Fn+F5. On installing Ubuntu this time, it worked.

share|improve this answer
    
where and when did he do fn+F5? During boot up? –  jaorizabal Mar 14 '12 at 21:46
1  
He did it in Windows after it was installed. –  jitendra Mar 15 '12 at 2:17
    
Thanks you helped me fix it –  jaorizabal Mar 15 '12 at 14:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.