Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After buying an Edimax EW-7811Un wirless adapter, I managed to get it working on my Ubuntu 11.10 system by following the solution described here.

This was working great until about a week ago when the adapter suddenly stopped working altogether. This happened after I installed a set of system updates on the 24th of December, so I suspect the updates either altered the driver or affected something the driver depends on.

I tried to re-apply the previous solution and found that Realtek have since released an update to the driver, so I tried installing this latest version and removed the driver from the modprobe blacklist (the blacklisting was part of the original solution).

I wasn't able to make the changes to the source code described in the original solution as the relevant code has since moved on and the lines I changed in the last version have now been commented out.

This got me to a point where I could connect to a network if I inserted the adapter after I'd logged into the system (logging in with the adapter already inserted caused the driver to get stuck in a loop, failing to connect and then re-trying), but after a few minutes the connection stopped working (I couldn't reach any other host), even though the taskbar widget reported that I was still connected to the wireless network.

Any suggestions would be greatly appreciated.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

The latest realtek driver doesn't require those changes, since, according to the release notes, the support for kernel 3.0.2 has been added. Keep the original module blacklisted, and simply run the install.sh script.

share|improve this answer
    
Thanks very much for the advice. I'd tried installing the new driver with the old one blacklisted, but this reverted back to the original problem of being able to see the network but not connect. However, given your comment about the improved kernel support I tried again and re-created my network connection config, which seems to have worked. Thanks very much! –  alphaloop Dec 31 '11 at 13:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.