Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have my Wacom Volito lightpen connected to USB port and trying to use it with Gimp. The problem is that every dozen (randomly) of lines it draws exact vertical, horizontal (randomly again) lines starting from where cursor is pointing to the edge of screen. Its always horizontal, vertical or 45deg lines. I tried to use different USB ports, checked my mouse and stylus on Windows (same laptop) and everything seems to be working fine. I checked them with Blender3D where it simply cancels my selection/action with the same time interval as in Gimp. Its noticeable with these programs especially (where I need precision) but of course it still appears with everyday use, only I noticed it recently while on Gimp/Blender;)

To me it seems like some kind of buffer overflow but I have no idea on how to get rid of the problem and I can't use my hardware if it occurs. Im using Lubuntu on Oneiric, tried regular Ubuntu- same story. Any ideas?

To make things absolutely clear- problem not occuring with mouse/lightpen movement, clicks only. I can move my controller freely when it happens. Another thing- nothing else is connected to my other USB ports so there shouldnt be any conflicts. I've plugged USB lamp in as a test and it also works well while mouse/lightpen goes crazy so no USB fault here I guess...

share|improve this question
    
I'm not sure a "USB lamp" can verify full USB functionality. Have you checked with Google google.com/search?q=Linux+Wacom+Volito+lightpen ? Have you read through the output of the dmesg command? Have you done any configuration changes to support the lightpen? Have you edited any configuration files? You might start with this askubuntu.com/questions/14008/… –  waltinator Dec 31 '11 at 21:02
    
well, plugging usb lamp may help verifying if USB stops working completely while using mouse, since the problem affects all the usb ports. Uncle Google says nothing about this particular case, thank you very much;) no configuration changes were done as it happens even when Im trying to use any controller with default settings just after installing Lubuntu/Ubuntu. reading dmesg was actually something I haven't done yet. Im on to it and I'll post it asap. And to be absolutely clear, no- never tried to use wacom drivers and to be honest it doesnt matter since it happens even with ANY MOUSE I use. –  Adam Kroczyk Jan 3 '12 at 15:51

1 Answer 1

up vote 2 down vote accepted

It's a known bug. There is a patch solution (comment 80) and a repo with patched GIMP, that worked for me.

The fastest way to solve the problem is to type in your terminal:

sudo add-apt-repository ppa:aapo-rantalainen/gimp26-noghostline
sudo apt-get update
sudo apt-get install gimp

This will apply a repo solution.

share|improve this answer
    
Thats exactly what needed to be done. Many thanks! –  Adam Kroczyk Jan 25 '12 at 2:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.