Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm currently using a LG laptop with Nvidia Cuda GeForce GT 335M.

I have difficulty adjusting the screen brightness using FN+Arrow Up/Arrow Down. The brightness indicator will appear and the bar will not decrease beyond the first jump. Subsequently, if I depress the button, the indicator bar will randomly appear to be dim and bright, with no actual difference to the screen brightness.

I have tried to adjust the brightness through System Settings>Screen. Although the bar can be dragged up and down, there seems to be no actual difference in the brightness.

Furthermore, after installing Ubuntu 11.10, I have difficulty adjusting the brightness in Windows 7 as well. The function button does not respond at all, and adjusting it through the Control Panel does not seems to have any actual difference.

What could be the problem?

I have tried to edit the /etc/X11/xorg.conf, and add the line Option "RegistryDwords" "EnableBrightnessControl=1", but it is not working for me.

share|improve this question

Try this: Confirmed working solution on clean Ubuntu 12.04 beta2 with 3.2.0-22 kernel with latest nvidia drivers. FN keys work, no need to make changes in grub or Xorg.conf

share|improve this answer

If the button is not working either in ubuntu or windows, then the problem may be coming from the button itself rather than ubuntu. I would have that button checked, maybe it is buged or some connection to the motherboard went MIA.

share|improve this answer
Hi, the button is definitely working. The problem here is that the brightness does not change with the input of the button, and the on-screen indicator of screen brightness refuses to change or have some random change which does not correspond to any actual difference in screen brightness. – Tan Zhong Xian Jan 8 '12 at 15:50
The button IS working but not properly....Maybe get it checked – Jester Jan 8 '12 at 22:40

try this on your terminal.

sudo setpci -s 00:02.0 F4.B=50
share|improve this answer
Hi, what does this command do? Nevertheless, I tried, but the terminal returns setpci: Warning: No devices selected for "F4.B=50" – Tan Zhong Xian Jan 8 '12 at 15:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.