Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been struggling for 3 days trying to dual boot Ubuntu 11.10 and Windows 7. I want to use an SSD for my Ubuntu installation and an hdd for Windows. I realized that I have to install windows first and then ubuntu, and so I did that. When I first install windows it boots fine from my hdd, but when I add ubuntu on my ssd and restart, I get a black screen with a blinking cursor. I've read many forums where this is asked but haven't found a single solution that works.

I've tried boot repair. It told me to make a fat ESP partition and I did that as well but it still doesn't work.

I'm a noob and any suggestions would be really appreciated.

share|improve this question
1  
Dual booting on separate drives is possible it just depends on which drive did you install GRUB on. Ideally you would have installed GRUB on the SSD drive and edit your bios settings to boot from it first, GRUB will detect the windows install and add it to the bootloader. –  Mark Rooney Dec 30 '11 at 4:38
    
Can you add any more information to your question? Which forum things did you try? –  Jorge Castro Dec 31 '11 at 18:34
    
I've had this problem as well. You could try to take a look at [this answer][1]. [1]: askubuntu.com/questions/115993/… –  LasseValentini Mar 27 '12 at 10:05
    
The question referenced by Fraekkert relates to a Linux/Windows XP dual boot, which is almost certainly NOT done on a UEFI-based systems. BIOS and UEFI dual-booting are two ENTIRELY different things, and solutions for one are unlikely to be helpful for the other. –  Rod Smith May 8 '12 at 16:42
add comment

3 Answers 3

Have you tried making a 200MB partition on the ssdhd for the uefi like windows has?

I don't know what format it has to be in but I am sure someone knows.

Try pulling the windows HD out then install Ubuntu (or distro of choice) then plug windows back in, set the boot order t ubuntu first then edit grub (grub2?) to add in windows.

If you can try the F12 trick at boot up and select the drive you want. Do it twice to see if both work.

Some IOS will allow you to disable UEFI.

On mine as soon as I do that Windows wants a R/R.

The only linux I can run is a DVD or flash live version.

If you can remaster the flash drive things should work 1/2 way better.

Or maybe use a USB 3.0 external drive and boot from that?

share|improve this answer
add comment

Unfortunately, you'll get a lot of completely unhelpful information on the Internet about this, since the boot process on UEFI-based systems is completely different from the boot process on older BIOS-based hardware. Completely describing the relevant differences in one post here is impossible, so for full information, I recommend you check out the Wikipedia page on UEFI and my Web page on EFI boot loaders for Linux. (Note that "UEFI" refers to the next generation of EFI; essentially EFI 2.x. For the most part, the two terms are interchangeable, although "UEFI" is more specific and refers to a newer version of the technology.)

To get you started, though, you should first verify that you are booting Windows in EFI mode. This can be done in a number of ways, such as typing "bcdedit" in an Administrative Command Prompt window. The result should include a reference to winload.efi in the "path" line of the "Windows Boot Loader" section. If instead this line refers to winload.exe, then the system is booted in BIOS mode, and you need to follow more conventional BIOS advice for this.

Assuming you're booted in EFI mode, my first advice is to forget about installing Ubuntu 11.10 or earlier. These versions include bugs in the installation process that make it much harder to set up a dual-boot with any other OS. Ubuntu 12.04 fixes the worst of these bugs. In 12.04 booted in EFI mode, the installer should detect the EFI System Partition (ESP; a partition that holds boot loaders) created by Windows and add its own boot loader to that partition.

One possible complication is that Ubuntu might not boot in EFI mode, even if Windows is installed in that mode. You can check this detail by looking for the directory /sys/firmware/efi. (You may need to use the "try before installing" option to check for this file, then launch the installer.) If This file is present, you're definitely booted in EFI mode. If not, you're probably booted in BIOS mode, although that's not 100% certain. If you find you're booting in BIOS mode, you should either correct that problem or go ahead and install in BIOS mode and switch your boot mode afterward. Either of those options is worth a whole new question here, so I won't go into them.

Ideally, if Ubuntu 12.04 installs correctly, it'll detect Windows and make GRUB 2 the default boot loader, so the system will work as expected, offering you a boot menu when you boot. Sometimes, though, you'll need to add Windows to the GRUB configuration, which you can do by creating an entry like this in /etc/grub.d/40_custom and then re-running "grub-mkconfig -o /boot/grub/grub.cfg":

menuentry "Windows 7" {
        set root='(hd0,gpt1)'
        chainloader /EFI/microsoft/BOOT/bootmgfw.efi
}

Other times the system may continue to boot straight into Windows. This can usually be corrected by deleting EFI/boot/bootx64.efi from the ESP, or perhaps replacing it with a copy of the GRUB 2 boot loader file (probably EFI/ubuntu/grub_x64.efi, IIRC). Unfortunately, this problem is caused by bugs in specific EFI implementations, so the workaround can be highly system-specific.

Your symptom of a black screen with a blinking cursor suggests a serious GRUB misconfiguration, or perhaps a completely missing GRUB installation. I'm going to duck this question by saying that with any luck it will be fixed by Ubuntu 12.04. If not, I recommend installing ELILO or Fedora's patched GRUB Legacy to replace GRUB 2, since in my experience GRUB 2 is the least reliable of the available Linux EFI boot loaders. (See the EFI boot loaders page I referenced in the first paragraph of this reply for details.)

share|improve this answer
add comment

Try to install the boot loader to the hdd in the Ubuntu setup, perhaps is a problem with the grub installation on the sdd.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.