Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying bind a button on my mouse to show the Gnome Shell Activities overview. I'm using xbindkeys to bind actions to my mouse buttons.

I tried using the following xte command to show the Activities overview:

xte 'keydown Alt_L' 'key F1' 'keyup Alt_L'

This works fine when executed in the terminal, but doesn't work with xbindkeys for some reason.

share|improve this question

4 Answers 4

I just found your Question over Google. I was searching for this Command. The Command xte 'keydown Alt_L' 'key F1' 'keyup Alt_L' works great with easystroke. You can find easystroke in the USC.


My English is not very got so i made a HowTo Picure. I hope it helps you http://ubuntuone.com/6sQIXcRIt7aP3SEzEKvRcC

share|improve this answer
    
I'm not sure that easystroke is what I'm looking for, I'm trying to trigger the action by clicking one of my mouse's extra buttons, not by using a mouse gesture. –  Rowno Dec 31 '11 at 0:14
    
You can bind commands to a single Mousebutton with easystroke. I am doing so. –  kmh42 Dec 31 '11 at 11:50
    
Well can you provide better explanation then? All I can see in easystroke is for recording mouse gestures. –  Rowno Jan 1 '12 at 0:47

I had the same problem. Here's what the command looked like in HOME/.xbindkeysrc:

xte 'keydown Control_L' 'key F1' 'keyup Control_L'
b:2

Note: The xbindkeysrc file was created with command :

xbindkeys --defaults > $HOME/.xbindkeysrc

(And this is obviously after installing xautomation.) I also changed the command in Gnome from Alt+F1 to Ctrl+F1 - just to see if that made a difference. It did, but only after installing and running Easystroke. I also changed the ALT/WIN to "Meta is Mapped to Left Win" based on some other posts but this didn't help. So:

  • After installing easystroke and starting it, the Ctrl+F1 combination worked (somehow, easystroke reset something that allowed xbindkeys to work, even though I assigned no actions in easystroke). If I turned off easystroke, xbindkeys also stopped working.

  • After installing easystroke and starting it, the Alt+F1 combination did not work (I obviously changed the keyboard combination back to ALT+F1). So, there's possibly some weirdness surrounding XTE, Gnome Shell and the Alt key?

I installed easystroke:

sudo apt-get install easystroke

Then Alt+F2 and typed in easystroke.

  • Adding the action in easystroke (assigned to Alt+F1) and turning off xbindkeys works.

So, if you're an average user like me, don't use xbindkeys in Gnome Shell (there are some weird bugs or conflicts going on), use easystroke. Easystroke just works. Remember to add easystroke to your startup applications.

share|improve this answer
up vote 2 down vote accepted

I got it working in the end by adding the release modifier to the xbindkeys config. I have no idea why the press event doesn't work but the release event does.

The final xbindkeys config ended up being:

"xte 'keydown Alt_L' 'key F1' 'keyup Alt_L'"
    release + b:10
share|improve this answer

I got it working running xbindkeys as root. My ~/.xbindkeysrc:

"xte 'keydown Alt_L' 'key F1' 'keyup Alt_L'"
release+b:9

P. S. Easystroke work for me as well, but if you bind stroke from only one key press, you had to press having mouse completely still. This was actually hard·

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.