Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 11.10, and when I connect my Kindle Fire to my computer via micro usb, it is not recognized automatically. Other usb devices, such as my ipod and digital camera, are recognized just fine.

It does not appear to be a usb power issue, since the Kindle Fire wakes up from sleeping when it is plugged in. I never get the message on the Kindle telling me it is ready to accept files from the computer, though.

Here are the last 15 lines of dmesg after plugging the kindle in:

jeff@prime:~$ dmesg | tail -n 15
[45918.269671] ieee80211 phy0: wl_ops_bss_info_changed: arp filtering: enabled true, count 1 (implement)
[45929.072149] wlan0: no IPv6 routers present
[46743.224217] usb 1-1: new high speed USB device number 5 using ehci_hcd
[46743.364623] scsi8 : usb-storage 1-1:1.0
[46744.366102] scsi 8:0:0:0: Direct-Access     Amazon   Kindle           0001 PQ: 0 ANSI: 2
[46744.366356] scsi: killing requests for dead queue
[46744.372494] scsi: killing requests for dead queue
[46744.384510] scsi: killing requests for dead queue
[46744.392348] scsi: killing requests for dead queue
[46744.392731] scsi: killing requests for dead queue
[46744.396853] scsi: killing requests for dead queue
[46744.397214] scsi: killing requests for dead queue
[46744.400795] scsi: killing requests for dead queue
[46744.401589] sd 8:0:0:0: Attached scsi generic sg2 type 0
[46744.407520] sd 8:0:0:0: [sdb] Attached SCSI removable disk

And here are my mounted filesystems:

jeff@prime:~$ df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda1            298594984 174663712 108763480  62% /
udev                   1407684         4   1407680   1% /dev
tmpfs                   566924       896    566028   1% /run
none                      5120         0      5120   0% /run/lock
none                   1417308       300   1417008   1% /run/shm
/home/jeff/.Private  298594984 174663712 108763480  62% /home/jeff

I should note that, since I got Dropbox working on my Kindle, the usb is no longer strictly necessary, but as a matter of principle I'd love to get it working.

share|improve this question
    
What software/application were you intending to use to talk to/control the Kindle Fire? Is it installed? –  david6 Jan 4 '12 at 22:26
    
@david6 You don't need an application. It works (both on Windows and Ubuntu) just like inserting a USB, and then manipulating files with a file-browser. –  Jjed Jan 4 '12 at 22:34

4 Answers 4

If you want to copy paste files in to Kindle Fire, you can do so by using gMTP. It opens up your kindle in the same manner as any USB device.

For more information, read this tutorial: http://itsfoss.com/how-to-connect-kindle-fire-hd-with-ubuntu-12-10/

share|improve this answer

I know it´s kind of old question but I had the same problem and I did what Jeremiah said @Jeff.
The only difference was that I didn´t put ext3 and make sure I created a directory for kindle on /mnt by using sudo mkdir /mnt/kindle. I hope I helped a little.

So this should work also:

sudo mount /dev/sdb/ /mnt/kindle
share|improve this answer

The Kindle Fire is reported to connect properly out of the box by several users. Just plug it in and look for a "Kindle Fire" icon to appear in your launcher sidebar. If not, try the technical solution below:

The approach I would take would be to mount the Kindle and then you can cp files over in the terminal or likely even the file browser. I'd start with dmesg as you've done and note which device node the Kindle is put on. Look for lines in dmesg like;

[149600.320060] usb 1-6: new high speed USB device using ehci_hcd and address 13

or similar and you should see a line like this as well;

[149602.666223] sd 4:0:0:1: [sdb] Attached SCSI removable disk

If you look at the last line above, you'll see 'sdb' in brakets, that is the device node that the new USB device is attached too. You can confirm this with

sudo ls -l /dev/disk/by-id/

You should see something like this;

lrwxrwxrwx 1 root root  9 Jan  7 20:01 usb-Generic-_SD_MMC_058F63646476-0:0 -> ../../sdb

Of coruse you'll see something different because I doubt the Kindle will identify itself as a generic SD MMC device.

You can mount that device as root with this command;

sudo mount -t ext3 /dev/sdb/ /mnt/kindle/

(that assumes you've created a directory called "kindle" under /mnt)

You should be able to see the Kindle in your file manager now. And you can also use the terminal and cd to /mnt/kindle which should show you a mounted Kindle file system.

Note that I haven't actually tried this since I don't have a Kindle and I'm only guessing at the actual file system which you supply to the -t flag for mount, but I'd bet its ext3.

share|improve this answer
2  
sudo mount -t ext3 /dev/sdc/ /mnt/kindle/ mount: no medium found on /dev/sdc - no such luck using above directions for my Kindle –  Twisted Pear Apr 3 '12 at 4:40

Don't know exact answer, but should be similar issue to when Kindle 3 released and not yet (automatically) recognized by Ubuntu 10.04 LTS.

Using Calibre with a Kindle 3 on Ubuntu 10.04

This just needs to be updated, and will probably (eventually) arrive as a system update.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.