Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
01:00.0 VGA compatible controller [0300]: nVidia Corporation Device [10de:1040] 
(rev a1)

thats what i get when I do

lspci -nn | grep VGA 

I'm running Ubuntu 10.04 , I'm getting really annoyed help please..

share|improve this question
    
what is your graphics card model? Did you install any additional driver? –  shantanu Dec 30 '11 at 11:35
add comment

1 Answer 1

This issue gets everyone in Lulliput shaking their cage...

Successfully configuring your display to use your graphics card depends on 2 things:

  • The Xserver config file at /etc/X11/xorg.conf
  • Having the correct Nvidia driver installed

Your graphics card appears to be an Nvidia GT520 (device code 10de:1040).

  1. Open Synaptic and completely remove any package with "nvidia" in the name.
  2. Go to System > Administration > Hardware drivers. Install or reinstall your Nvidia driver and accept the recommended Nvidia proprietary driver.
  3. Install the package nvidia-settings via Synaptic and after a reboot run the following:

    $ sudo nvidia-settings

Configure your display and then click "Save Current Settings", then reboot again. You should now have a xorg.conf file with the Device section something like the following:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT520"
EndSection

If at this point, you are still having no joy, it's time to get heavy handed, so try each of the following and repeat from the top.

$ sudo dpkg-reconfigure xserver-xorg

or

& sudo rm -rf /etc/X11/xorg.conf
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.