Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I ran powertop, and it says that the Realtek audio codec is using 100.0% of the cpu. Is this a problem?

I'm running Ubuntu 11.10 32-bit on Intel® Core™ i7 CPU M 640 @ 2.80GHz × 4 Sony VAIO laptop.

share|improve this question
It says that it's active 100% of the time, not that it uses 100% of the CPU. ;) I don't see it causing any trouble here. – htorque Dec 29 '11 at 19:44
up vote 5 down vote accepted

No, it just means that you have (probably digital) sound output enabled. If you have some sound outputs, such as digital (optical/coaxial) or hdmi you are not using, then you can blacklist their drivers and you might save some battery. They will be listed in lsmod something like, snd_hda_code_realtek and snd_hda_codec_hdmi. By adding these to /etc/modprobe.d/blacklist.conf you can disable them.

share|improve this answer

Try changing "Enable Audio codec power management" to good in the Tunables tab for powertop. After doing so, hwC0D0 is no longer listed in powertop for me.

share|improve this answer

I found that muting the microphone input in the mixer solved the problem. I use a Dell XPS17.

share|improve this answer

Muting / disabling stuff with alsamixer helped me get rid of the same problem on macbook air.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.