Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I built a new htpc about 2 months ago and installed Ubuntu 11.10 x86_64. The system records TV with MythTV. I use MythTv and Boxee for playback. After 15 minutes up to 6 hours of video playback, something causes playback to drop to about 1-2 fps. AC3 passthrough audio stutters at the same rate, but pulse audio remains normal. Logging out resets/fixes the issue, but the stuttering will start again after another 15 minute to 6 hours of playback (I haven't noticed a correlation with the varying times). Getting up a few times during a program to log out, log back in, restart the video is getting annoying.

The video card is an Nvidia Geforce GT 520. I've experienced this issue with both VDPAU and software decoding. Connection is HDMI to a 1080p TV. I use the Nvidia HDMI audio.

I tried the ubuntu-x-swat PPA, but there was no change, so those lines are now commented out of my apt sources.

I've been using Ubuntu for about 5 years and am generally pretty savvy, but this one's got me stumped.

(Hopefully) relevant system data:

$ dpkg -l | grep nvidia
ii  nvidia-common                          1:0.2.35                                           Find obsolete NVIDIA drivers
ii  nvidia-current                         290.10-0ubuntu1~oneiric~xup1                       NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-current-updates                 280.13-0ubuntu5                                    NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-settings                        290.10-0ubuntu1~oneiric~xup1                       Tool of configuring the NVIDIA graphics driver
ii  nvidia-settings-updates                280.13-0ubuntu1                                    Tool of configuring the NVIDIA graphics driver

$ uname -a
Linux t3 3.0.0-14-generic #23-Ubuntu SMP Mon Nov 21 20:28:43 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

$ dmesg | grep -i nvidia
[   65.630897] nvidia: module license 'NVIDIA' taints kernel.
[   66.195170] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input5
[   66.195215] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input6
[   66.195328] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[   66.195334] nvidia 0000:01:00.0: setting latency timer to 64
[   66.195427] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  280.13  Wed Jul 27 16:53:56 PDT 2011

EDIT: (summary of comments) I started logging GPU temperature to see if there was any correlation to the stuttering. I have not found a correlation.

I've also noted that it will sometimes go into 1-2 fps stuttering mode while sitting idle for a few hours; it stutters the next time it is used, and I must log out, log back in to clear it.

share|improve this question
    
have a look at nvidia-settings - look at your card temperature - is it hot when its stuttering? –  fossfreedom Dec 29 '11 at 18:44
    
It usually hovers around 29C. One thing I didn't mention: it will go into 1-2 fps mode when idle (TV off), too--evident when turning it back on and attempting to play video. –  Tom Dec 29 '11 at 22:53
    
I'm logging the GPU temp now. The temp climbed to 38C while in use, started stuttering. I closed the video app and the temp dropped again to 29C. Opened Boxee and the graphics-accelerated menus and video were still stuttering. Exited, logged out, logged back in and it's normal again (for a few minutes anyway). If you're curious, here's my crontab line for the GPU temp logging: * * * * * echo `date`: `nvidia-smi -q | grep -A 1 Temperature | tail -n 1 | awk '{print $3,$4}'` >> /home/tom/gpu.log –  Tom Dec 29 '11 at 23:40
    
Just happened again at 30C. No correlation to temperature. –  Tom Dec 30 '11 at 3:32
    
@JorgeCastro Done. I would have thought comments would bump the question! –  Tom Jan 1 '12 at 0:05
show 1 more comment

1 Answer 1

up vote 0 down vote accepted

This problem was resolved after a recent package upgrade. One of the packages that updated was the kernel, but I'm not certain which package fixed the problem.

I'm now running this Ubuntu kernel version:

Linux 3.0.0-15-generic #25-Ubuntu SMP Mon Jan 2 17:44:42 UTC 2012 x86_64
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.