Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using Lucid, in the form of Turnkey Core. I'm setting up Grub to boot into Windows by default, with an option to boot into Ubuntu as a recovery mode, with a script to restore a default image to the Windows partition.

The idea is to have a splash screen which tells the user to hold Shift for recovery options, otherwise it'll just boot to Windows.

Unfortunately, while I can get my splash screen to work, it doesn't show up until I press a key -- doesn't seem to matter which key, as arrow keys, letters, and numbers all seem to work. At that point, the splash screen shows up and displays at the top left corner -- this appears to be the GRUB_HIDDEN_TIMEOUT, and the number updates every time I press a key; otherwise, it remains static until the actual countdown has finished. (I guess this indicates that it is also not showing the countdown, which it should be doing, as GRUB_HIDDEN_TIMEOUT_QUIET is set to false.) Everything functions normally from this point: If I hold Shift, the menu is displayed, otherwise it boots into Windows.

Got the menu to be hidden in multi-OS mode by using #11 here.

Any ideas?

Clarification: My issue is that the splash screen does not appear until I press a key. I need the splash screen to show up on its own.

Contents of /etc/default/grub and /boot/grub/grub.cfg available here

share|improve this question
    
1. Why turnkey? Is there a virtual appliance for windows image recovery? 2. I didn't understand what is the exact question. I don't think you can set a specific key (e.g. only Shift) to which grub opens up. There's GRUB_DEFAULT_BUTTON ( gnu.org/software/grub/manual/grub.html#Simple-configuration ) but I think that is for power-on buttons pre-defined by the computer vendor ( gnu.org/software/grub/manual/grub.html#Vendor-power_002don-keys ). 3. Did you fix what you asked for or are you still facing problems? –  medigeek Dec 29 '11 at 17:20
    
No, I want the menu to come up when I hold "Shift." That's fine. The trouble is that the splash screen doesn't show up until I press some key -- any key. Without the splash screen, there's no way to prompt the user to open the Grub menu. As for Turnkey, no, there's not an appliance for recovery -- Turnkey Core is just the most minimal preconfigured distro I could find with the necessary tools. I'm pretty sure it's not causing the problem, but I can use something else if it turns out to be the issue. –  jdw Dec 29 '11 at 17:35
    
Huh? Grub doesn't support a splash screen. –  psusi Dec 29 '11 at 19:13
    
help.ubuntu.com/community/Grub2#Hidden -- the documentation here appears to suggest it does, and should show up even if the menu is hidden. –  jdw Dec 29 '11 at 20:08
    
try adding more than one boot options. Can you add the content of files /boot/grub/grub.cfg and /etc/default/grub to your question? It will probably shed more light. –  medigeek Dec 29 '11 at 22:42

1 Answer 1

Posted as the answer on behalf of OP:

After receiving a suggestion to ignore the splash screen entirely, and just use nested Grub menus, I decided to give that a shot. In the process, I found out that I can create a Grub menu which has a timeout of 0 and automatically loads another Grub via configfile, and, in so doing, actually triggers the splash screen on the second menu. So, grub.cfg now contains this, with default set to 1 and the timer set to 0:

menuentry "Other menu" { configfile (hd0,1)/boot/grub/othergrub.cfg }

When it loads the second Grub, the splash screen from the second Grub loads up just fine, too -- no keypresses required.

Weird workaround, but it does the trick.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.