Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A complete new install of lubuntu 11.10 has synaptic 0.75.2ubuntu7. Previously when using synaptic on another system there was a search box in the tool bar where a search string could be entered which would reduce the displayed packages as the string was being entered. The box is not being displayed nor do I find any setting to enable/disable it.

share|improve this question
this is still a bug in 12.10 Lubuntu however solved with the answer provided – Ringtail Nov 29 '12 at 3:47
experienced in lubuntu 15.10, fixed with provided answer – Al F Feb 25 at 15:50
up vote 37 down vote accepted
sudo apt-get install apt-xapian-index
sudo update-apt-xapian-index -vf


share|improve this answer
Unfortunately this solution does not work for me (ubuntu x64 12.10 fresh install) – JoZ3 Apr 10 '13 at 17:12
works for ubuntu 16.04 – jumpjet67 Apr 8 at 6:15
Needed this in Ubuntu GNOME 16.04 as well. – zeitue Apr 23 at 1:14

If the other answers don't help then try:

sudo apt-get install --reinstall synaptic
sudo dpkg-reconfigure synaptic

It worked for me.

share|improve this answer

forums linuxmint suggests installing apt-xapian-index when the box is present but grayed out. This solution also works in this case where the Quick Filter box is completely missing.

share|improve this answer

LionHater's solution just cured the problem for my Ubuntu 16 64 bit Gnome. I tried reinstalling Synaptic first which did not cure the problem, but it is possible that needs to be done first, no way to tell at this point.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.