Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have purchased new vodafone usb modem (ZTE K3770-z) and tried to connect it with ubuntu 11.04. But it is not automatically detected on ubuntu.


I have installed windows 7 and ubuntu 11.04 on my laptop.

To detect the modem on ubuntu I did the following steps :-

1) Connect the modem with laptop and boot the machine with windows 7 2) After detecting the modem on wndows, restarted the machine and enter into ubuntu.


Does anyone know any solution to detect the modem automatically on ubuntu?

Thanks in advance.

share|improve this question
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. I am flagging this for closure. Regards, –  Ringtail Mar 9 '12 at 1:43
    
@blueXrider: why would you like to close this question?.. May i know the reason ?. –  aneeshep Apr 17 '12 at 11:16
    
This question appears to be abandoned. No activity. No answers. meta.askubuntu.com/questions/2651/ask-ubuntu-clean-up –  Ringtail Apr 17 '12 at 14:46
    
@blueXrider: Ok then close it. But I am still facing this issue. let me try on 12.04. if it is not working i will post another question. is that ok?.. –  aneeshep Apr 23 '12 at 13:09
    
It works in 13.10? or 12.04.4? –  Braiam Feb 9 at 20:31
add comment

3 Answers

open Synaptic Package Manager Type "Smartlink" into the search field in the Synaptic Package Manager and install all of smarlink package. http://www.ehow.com/how_5435902_install-modem-drivers-ubuntu.html#ixzz2BcaT8Ean it works with me very well

share|improve this answer
add comment

Install usb-modeswitch:

sudo apt-get install usb-modeswitch

share|improve this answer
2  
What is it? What does it do? Why is it necessary? Why would this solve the OPs issue? Add a bit more information to the answer please, it is recommended and important. –  Bruno Pereira Mar 14 '12 at 9:51
add comment

May be late for you, but try this in your Windows 7 OS:

Go to Device ManagerUniversal Serial Bus ControllerGeneric USB Hub (right-click) → Properties → under Power Management tab, un-check "Allow the computer to turn off dis device to save power".

This may work.

share|improve this answer
1  
and try doing it for all devices under "Universal Serial Bus Controller"... –  Diwas Oct 25 '12 at 9:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.