Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am new to Linux and Ubuntu (11.10, Oneiric Ocelot), so if there is some type of installer that I can double-click, that would be great. Otherwise, can you help me understand what's happening here.

After downloading gmp-5.0.2.tar.bz2 and extracting it to my Documents folder, I followed these instructions, but I'm hitting an error:
louis@x-pc:~/Documents/gmp-5.0.2$ ./configure
[checking various things...]
checking for suitable m4... configure: error: No usable m4 in $PATH or /usr/5bin (see config.log for reasons).
louis@x-pc:~/Documents/gmp-5.0.2$ make
make: *** No targets specified and no makefile found. Stop.

config.log is actually 180KB, and I really wouldn't know what to look for.

Can you tell me what I should do?

share|improve this question
Is the m4 package installed? (run "sudo apt-get install m4" in terminal), then try ./configure again. Or if you don't feel confortable using the terminal, use the Ubuntu packgae manager to install m4. – Niclas Nilsson Dec 29 '11 at 9:25
@NiclasNilsson Thank you. That worked. – Louis Dec 29 '11 at 9:29
Glad it helped! :) – Niclas Nilsson Dec 29 '11 at 9:31
@NiclasNilsson you should post that as an answer and Louis should accept it, now that it is confirmed working. This will help both your reputations here. – Tom Brossman Dec 29 '11 at 9:44
I know but it seemed silly to post an answer when I already solved it in the comment (was'nt sure that was the problem). But ok. – Niclas Nilsson Dec 29 '11 at 10:12
up vote 3 down vote accepted

Ok, here is my answer, so you can accept it and we both gain some points.

You have to install the m4 package.

Use the Ubuntu Package Manager or in terminal print sudo apt-get install m4

share|improve this answer

Installing from the Ubuntu software centre is a breeze! I highly recommend if you are new to Ubuntu that you start there. You can also install "Synaptic package manager" and install applications that way.

share|improve this answer

You shoul install software from Ubuntu Software Center. It's easier and more straigth forward. There is also an online app site here

share|improve this answer
He wants GMP, not GIMP. Software Center is still the easiest, best way for everything else though. – Tom Brossman Dec 29 '11 at 9:47
K, sorry, haven't been paying 100% attention :) – bioShark Dec 29 '11 at 10:07
I read it as GIMP the first time, too. When I clicked the link in the question I realized it was not a mistake. Something looked way off with the version number, too. (GIMP current stable version = 2.6) – Tom Brossman Dec 29 '11 at 10:14

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.