Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've noticed that after you double click on a raw image (NEF for me) in shotwell it produces a jpeg file. Before double clicking if I looked at View > Extended Information (EXIF) it showed correctly, but after jpeg is generated, there is no EXIF data available, so one has to open the file browser and navigate to the original NEF photo in order to look at the EXIF data.

Is there a way to program (am I missing something?) shotwell to retrieve the EXIF from the NEF files after the jpegs are generated?

share|improve this question

First see if this bug is affecting you, where Shotwell is using the small embedded jpeg from the NEF instead of the paired (higher-resolution) jpeg. Are the these jpeg files very low quality?

If not, check that you have Shotwell set to write metadata to files in Edit/Preferences like this:

enter image description here

share|improve this answer
Thanks for the replay. I missed that Metadata option in the Edit/Preferences. But it seems that even with the option checked it's not updating the EXIF data in JPEGs. When I double click on a newly imported RAW file, it generates a JPEG file (and with that option checked) it does show a progress bar and says that it's writing some metadata, but when I look at the extended information at the JPEG files it gives no information on lens.. etc. I am not affected by that bug and I'm not shooting RAW+JPEG, just RAW, and the JPEG is generated by Shotwell. – razvanc Dec 30 '11 at 8:30
@razvanc I have a Nikon too and I just tried this. I can confirm that this is the same on my machine. I can't find any info on why this is on Shotwell's site, so I recommend filing a bug / feature request. How-to is on their FAQ page here: You can also give Darktable a try, to work directly on the NEF files. Both programs are great but neither does everything I want. – Tom Brossman Dec 30 '11 at 10:19
Thanks for your time and pointing me in the right direction. – razvanc Dec 30 '11 at 15:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.