Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In last few days my Ubuntu 11.10 update manager is unable to get new updates. When I checked update log I saw that for couple of updates it says "Network isn't available". For other updates it downloaded logs and and internet connection also works fine.

Unable to attached screenshot due to SPAM prevention policy. But for below Release gpgv:/var/lib/apt/lists/partial/extras.ubuntu.com_ubuntu_dists_oneiric_Release.gpg

it says "Network isn't available"

For all other Releases it is downloading fine. And due to this I dont see any update available in last 10 days.


LOG OF sudo apt-get update:

dipen@EIDLCPU1018:~$ sudo apt-get update 
[sudo] password for dipen: 
Ign http:/extras.ubuntu.com oneiric InRelease
Ign http:/archive.canonical.com oneiric InRelease                                  
Ign http:/archive.canonical.com lucid InRelease                                     
Get:1 http:/extras.ubuntu.com oneiric Release.gpg [72 B]                            
Get:2 http:/archive.canonical.com oneiric Release.gpg [198 B]                                                      
Hit http:/extras.ubuntu.com oneiric Release                                                                          
Get:3 http:/archive.canonical.com lucid Release.gpg [198 B]                         
Err http:/extras.ubuntu.com oneiric Release                                                                

Hit http:/archive.canonical.com oneiric Release                                                            
Ign http:/archive.canonical.com oneiric Release                                                            
Hit http:/archive.canonical.com lucid Release                                                              
Ign http:/archive.canonical.com lucid Release                                        
Ign http:/archive.canonical.com oneiric/partner i386 Packages/DiffIndex              
Ign http:/archive.canonical.com oneiric/partner TranslationIndex                    
Ign http:/archive.canonical.com lucid/partner i386 Packages/DiffIndex
Ign http:/archive.canonical.com lucid/partner TranslationIndex
Hit http:/archive.canonical.com oneiric/partner i386 Packages 
Hit http:/archive.canonical.com lucid/partner i386 Packages   
Ign http:/dl.google.com stable InRelease                                            
Ign http:/archive.canonical.com oneiric/partner Translation-en_IN                   
Ign http:/archive.canonical.com oneiric/partner Translation-en
Ign http:/archive.canonical.com lucid/partner Translation-en_IN                     
Ign http:/archive.canonical.com lucid/partner Translation-en                        
Ign http:/in.archive.ubuntu.com oneiric InRelease                            
Ign http:/in.archive.ubuntu.com oneiric-updates InRelease
Ign http:/in.archive.ubuntu.com oneiric-security InRelease
Get:4 http//dl.google.com stable Release.gpg [198 B]
Get:5 http//in.archive.ubuntu.com oneiric Release.gpg [198 B]
Get:6 http//in.archive.ubuntu.com oneiric-updates Release.gpg [198 B]
Get:7 http//in.archive.ubuntu.com oneiric-security Release.gpg [198 B]
Hit http:/in.archive.ubuntu.com oneiric Release          
Ign http:/in.archive.ubuntu.com oneiric Release                      
Hit http:/in.archive.ubuntu.com oneiric-updates Release              
Err http:/in.archive.ubuntu.com oneiric-updates Release              
 Hit http:/in.archive.ubuntu.com oneiric-security Release             
Ign http:/in.archive.ubuntu.com oneiric-security Release             
Ign http:/in.archive.ubuntu.com oneiric/main i386 Packages/DiffIndex 
Ign http:/in.archive.ubuntu.com oneiric/restricted i386 Packages/DiffIndex
Ign http:/in.archive.ubuntu.com oneiric/universe i386 Packages/DiffIndex
Ign http:/in.archive.ubuntu.com oneiric/multiverse i386 Packages/DiffIndex
Hit http:/in.archive.ubuntu.com oneiric/main TranslationIndex
Hit http:/in.archive.ubuntu.com oneiric/multiverse TranslationIndex
Hit http:/in.archive.ubuntu.com oneiric/restricted TranslationIndex
Hit http:/in.archive.ubuntu.com oneiric/universe TranslationIndex
Ign http:/in.archive.ubuntu.com oneiric-security/main i386 Packages/DiffIndex
Ign http:/in.archive.ubuntu.com oneiric-security/restricted i386 Packages/DiffIndex
Ign http:/in.archive.ubuntu.com oneiric-security/universe i386 Packages/DiffIndex
Ign http:/in.archive.ubuntu.com oneiric-security/multiverse i386 Packages/DiffIndex
Hit http:/in.archive.ubuntu.com oneiric-security/main TranslationIndex
Hit http:/in.archive.ubuntu.com oneiric-security/multiverse TranslationIndex
Hit http:/in.archive.ubuntu.com oneiric-security/restricted TranslationIndex
Hit http:/in.archive.ubuntu.com oneiric-security/universe TranslationIndex
Hit http:/in.archive.ubuntu.com oneiric/main i386 Packages
Hit http:/in.archive.ubuntu.com oneiric/restricted i386 Packages
Hit http:/in.archive.ubuntu.com oneiric/universe i386 Packages
Hit http:/in.archive.ubuntu.com oneiric/multiverse i386 Packages
Hit http:/in.archive.ubuntu.com oneiric/main Translation-en
Hit http:/in.archive.ubuntu.com oneiric/multiverse Translation-en
Hit http:/in.archive.ubuntu.com oneiric/restricted Translation-en
Hit http:/in.archive.ubuntu.com oneiric/universe Translation-en
Hit http:/in.archive.ubuntu.com oneiric-security/main i386 Packages
Hit http:/in.archive.ubuntu.com oneiric-security/restricted i386 Packages
Hit http:/in.archive.ubuntu.com oneiric-security/universe i386 Packages
Hit http:/in.archive.ubuntu.com oneiric-security/multiverse i386 Packages
Hit http:/in.archive.ubuntu.com oneiric-security/main Translation-en
Hit http:/in.archive.ubuntu.com oneiric-security/multiverse Translation-en
Get:8 http//dl.google.com stable Release [1,347 B]
Hit http:/in.archive.ubuntu.com oneiric-security/restricted Translation-en
Hit http:/in.archive.ubuntu.com oneiric-security/universe Translation-en
Get:9 http//dl.google.com stable/main i386 Packages [1,214 B]                                                                                       
Ign http:/dl.google.com stable/main TranslationIndex                                                                                                
Ign http:/dl.google.com stable/main Translation-en_IN                                                                                               
Ign http:/dl.google.com stable/main Translation-en
Fetched 3,821 B in 41s (91 B/s)
Reading package lists... Done
W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http:/extras.ubuntu.com oneiric Release: The following signatures were invalid: BADSIG 16126D3A3E5C1192 Ubuntu Extras Archive Automatic Signing Key <ftpmaster@ubuntu.com>

W: GPG error: http:/archive.canonical.com oneiric Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
W: GPG error: http:/archive.canonical.com lucid Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
W: GPG error: http:/in.archive.ubuntu.com oneiric Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http:/in.archive.ubuntu.com oneiric-updates Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>

W: GPG error: http:/in.archive.ubuntu.com oneiric-security Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
W: Failed to fetch http:/extras.ubuntu.com/ubuntu/dists/oneiric/Release  

W: Failed to fetch http:/in.archive.ubuntu.com/ubuntu/dists/oneiric-updates/Release  

W: Some index files failed to download. They have been ignored, or old ones used instead.
dipen@EIDLCPU1018:~$ 

LOG of sudo apt-get upgrade:

dipen@EIDLCPU1018:~$ sudo apt-get upgrade 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  ghc6-doc haskell-zlib-doc libghc6-zlib-doc
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
dipen@EIDLCPU1018:~$ 

/etc/apt/sources.list:

deb http:/in.archive.ubuntu.com/ubuntu/ oneiric main restricted
deb http:/in.archive.ubuntu.com/ubuntu/ oneiric-updates main restricted
deb http:/in.archive.ubuntu.com/ubuntu/ oneiric universe
deb http:/in.archive.ubuntu.com/ubuntu/ oneiric-updates universe
deb http:/in.archive.ubuntu.com/ubuntu/ oneiric multiverse
deb http:/in.archive.ubuntu.com/ubuntu/ oneiric-updates multiverse
deb http:/archive.canonical.com/ubuntu oneiric partner
deb http:/in.archive.ubuntu.com/ubuntu/ oneiric-security main restricted
deb http:/in.archive.ubuntu.com/ubuntu/ oneiric-security universe
deb http:/in.archive.ubuntu.com/ubuntu/ oneiric-security multiverse
deb http:/extras.ubuntu.com/ubuntu oneiric main #Third party developers repository
deb http:/archive.canonical.com/ lucid partner
share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

You have a few issues that need to be corrected:

Open a terminal and type

sudo nano /etc/apt/sources.list

Look for lines that have lucid in them for example

deb http:/archive.canonical.com/ lucid partner

Add a # to the beginning of the line to comment it out - for example

#deb http:/archive.canonical.com/ lucid partner

Save and re-run

sudo apt-get update && sudo apt-get upgrade

You have a number of errors with BADSIG - this is due to the security certificate not being downloaded correctly. You can correct this by following the instructions in the linked Q&A below.

After correcting the BADSIG errors re-run:

sudo apt-get update && sudo apt-get upgrade

Linked Question:

  1. What is the easiest way to resolve apt-get BADSIG GPG errors?

`

share|improve this answer
    
Hi fossfreedom, I tried all of above but still error remains. If I remove /var/lib/apt/lists directory and rebuild everything via sudo apt-get update then no issue. But next day onwards it will start showing same errors again. –  dPEN Dec 31 '11 at 9:26
    
please update your question with the latest values of each of update/upgrade & sources.list –  fossfreedom Dec 31 '11 at 12:20
    
Hi Fossfreedom, After performing all your steps again I got rid of all errors. And now update-manager is able to download and update my system. Thank you. --Dipen Patel –  dPEN Jan 3 '12 at 5:16
add comment

Can you ping an external site from the terminal? Try something like:

$ ping google.com

If it works, you don't have connection problems.

Try running the updates via apt-get:

# apt-get update

and then:

# apt-get upgrade

Does these work?

If you can, try to see what the source list is for apt:

# more /etc/apt/sources.list

Does the entries look OK?

Also, to be on the safe side, you are using Ubuntu 11.10 and just trying to get software updates, right? You are not trying to dist-upgrade?

share|improve this answer
    
Hi Tayfun, Thanks for quick response. Ping works and it is same computer I am typing this request so N/W works fine. I have edited my post with console log of apt-get update and upgrade and also /etc/apt/sources/list for your reference. –  dPEN Dec 30 '11 at 8:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.