Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have to do some screencast tutorials and i am using recordmydesktop with gtk frontend to do it. I need to record also the sound and here is where i have found the problem.

It took me some time, but now I can record the sound from almost every application in my desktop ... almost.

I need to capture some sound from a web application using java, but when i load the page nothing appears in the playback tab of pavucontrol. I think this is the problem, because if there is no sound stream i think the recordmydesktop program thinks there is no sound to record ... the funny thing is that I can ear the sound in my speakers!

I have tried with Firefox and Chromium with no success.

Although I have been able to record youtube videos without problem, so it seems that java is the key here.

Any suggestion or idea?

P.S.: I am using Ubuntu 11.10 with this configuration. ( if more information is needed please let me know) sight i cannot post images ... so

I have an audigy2 sound card using Analog Stereo Output profile. I have also an "Internal Audio" device, but i have it with the "Off" profile. In recordmydesktop->Advanced->Sound: Device = default

share|improve this question
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. I am flagging this for closure. Regards, – Ringtail Mar 11 '12 at 15:32
  1. Using the preview thumbnail on the main window.
  2. Using the “Select Window” button.
  3. Using the “Select Area on Screen” function of the tray pop up menu.

-To select on the thumbnail, simply left click on it and drag the mouse. Release it when you have covered the area that you want recorded. Right clicking on the preview widget will restore the recording area to full screen.

-To confine the recording on one window, click on the “Select Window” button. The cursor will change to a cross. Now click on the window you wish to record and the area will be selected. Using the “Select Window” button will only set the area. If you move the window, the area will remain unchanged. By default the window decorations will be included in the recording area. This can be changed at Advanced->Misc. To use the “Select Window” button, you need to have the xwininfo utility installed.

-Finally, to select an area with more precision, right click on the tray icon and click on “Select Area on Screen”. When you do that, a screenshot of your desktop is picked and then overlayed as full screen over your desktop. Left click and drag to select an area. When you release the mouse button, the overlayed screenshot will disappear. You can also right click to cancel the selection process.

-After you have finished using any of the above methods, the area you have selected will be shown in the the preview window. Depending on your settings, an optional frame might also appear on your real display, around the recording area. enter image description here source

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.