Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install a driver but after antony@antony and password etc cd /home/you-user-name/Downloads and then typed ./ I get permission denied. Can someone tell me how to solve this install to the driver please or how to go about doing it a better way.

Ok the commands chmod u+x sudo ./ Didnt work

So Using the file permission suggested by Javier the driver runs but I get the follow message. You are running a x86 machine with libc5

you need to run this installer as the super user. Any suggestions? or should I open a new question

Should I use the restricted drivers utility and if so how do I do that?

Catalyst gives me.. For further configuration of the driver, please run anticonfig from a terminal or AMD CCC:LE from desktop Manager Menu.. I ran sudo aticonfig --initial after antony@antony and got command not found.

uname -a gives 3.0.0-12-generic hash20-ubuntu SMP

The ati site is offering a the same driver for 32b again the at is it a problem at or should I update 11.10 32b to 64b and start again?


share|improve this question
BTW: Have you tried to use the restricted drivers utility? – Javier Rivera Dec 28 '11 at 12:12
@JavierRivera..No I dont think so how do I do that? – Antony Dec 28 '11 at 12:35
the kernel you have installed - is that from the 32bit ubuntu desktop install CD or something else? – fossfreedom Dec 28 '11 at 13:39
@fossfreedom .. I installed 11.10 x32 to cd and installed from there. thanks – Antony Dec 28 '11 at 13:41
ok - I'm a little confused with the question you have now - have you managed to install the driver? Is the only thing you havent done is run sudo aticonfig --initial to complete the installation? – fossfreedom Dec 28 '11 at 13:45
up vote 3 down vote accepted

There can be two problems here, you could need superuser rights to be able to execute the file and the file should have execute permissions. So try:

chmod u+x
sudo ./

Both command should be run after cding to Downloads.

You can also assign execute permissions using the GUI. Rigth click the file and select properties. In the new window go to the permission, you should be able to change it from there.

enter image description here

share|improve this answer
Hi Thanks see above I have modified the question as its moved along a little thanks – Antony Dec 28 '11 at 12:09

Copy the file that you want to install to your /home/(user name)/Downloads/ folder or any folder under your home directory then try to install it under root, then you can install it.

share|improve this answer
You may want to edit this for clarification, as it's not clear what "try to install it under root" means. Assuming you're saying to perform the installation as root, you may want to include information (including specific commands) about how to do this. – Eliah Kagan Jun 21 '12 at 0:16

From my experience we cannot execute or install any application from partitions other than root and home. If we have any application on other partitions which are mounted under /media or other mount points, we cannot install them directly. To install it we need to copy it under root partition or /home directory/partition(If you have separate home partition).

If you still cannot install it, then check the application permissions. The application must have executable permission enabled (as root run chmod a+x

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.