Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I ssh into my server all but one of my users has the color scheme. The one that doesn't, well everything shows up as gray text. Is there a way I can change this color scheme?

Also, why would that one user's color scheme allow for only gray text when I ssh from putty, while the others have the different file types colored? My server is ubuntu with gnome and when I go into the terminal, this user has a color scheme (ex. ls command lists folders as light blue and bold)

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Normally you would set colors in ~/.bashrc

Perhaps copy the ~/.bashrc from another user or /etc/skel/.bashrc

What colors do you want to set ? Prompt? ls ?

share|improve this answer
    
I tried both, neither worked =(. I just want the default colors that show up for all other users. I haven't changed any of these settings (to my knowledge) for the user that doesn't have a color scheme showing up. –  user784637 Dec 28 '11 at 0:22
1  
I understand "colors" are not working, but I can not tell from what you posted if the problem is with .bashrc or your putty configuration , nor am I certain what colors ? you mean colors in command output such as ls ? colors in the prompt ? Can you ssh in (rather then putty) and confirm that the .bashrc is the same between users and that you are not sourcing a file ? –  bodhi.zazen Dec 28 '11 at 1:05
    
Thanks for the clarification, I was unsure what you were asking. I mean the colors in the command output. I just ssh'd and when I run ls, the output is colored for all but one user. I don't think the problem lies in putty. What do you mean by sourcing a file? I deleted the .bashrc for the problem user and copied over a .bashrc from a user with the colored command output but I'm still having the same problem =( –  user784637 Dec 28 '11 at 1:14
    
Okay, I realized the problem. There was a conflict w/ some stuff in .bash_profile, thanks for all your help =) –  user784637 Dec 28 '11 at 1:20
1  
glad you got it sorted. –  bodhi.zazen Dec 28 '11 at 4:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.