Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am facing a slightly weird issue. GUI's of eclipse, emacs or vim do not work on my comp. Please see the processor usage at the top in http://www.cse.iitb.ac.in/~namitk/eclipse.png, http://www.cse.iitb.ac.in/emacs.png (Also see vim.png at the same url). When I run these programs, the processor usage shoots up but the program GUI fails to load completely (for e.g in emacs/vim - the cursor never appears). I have tried waiting for 10-15 mins just in the hope - but nothing loads. I think its a GUI issue because the non-gui versions (emacs -nw and vi/vim) work normally without any issues. Has anyone faced such an issue previously? Could someone please suggest a way of debugging this issue?

My configuration is (output of uname -a) Linux namit-ThinkPad-T61 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 i686 i686 i386 GNU/Linux.

Please let me know if any other info is needed.

share|improve this question
add comment

1 Answer 1

Was due to a very trivial reason. I clicked on the Maximize button of my browser and observed that it hung up (stopped responding) and the processor usage shot up. Also the terminal from which I had started my browser showed a handful of "Gdk-CRITICAL **: IA__gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed" errors. I remember reading that this is a theme issue. I started emacs and maximized its window and it too worked flawlessly. Same with almost all applications - they hang up on reduced window size but work fine in maximized form. Also changing the theme (Any except radiance / ambiance) fixes this issue and I could use applications in maximized or reduced size.

On a side note, is the theme issue persistent or has been fixed?

share|improve this answer
    
Well done for finding an answer - however, remember, since this is a Q&A site, try not end an answer with another question. Feel free to ask another question if it hasnt already been asked. –  fossfreedom Dec 29 '11 at 11:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.