Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

At first, my modem was only detected by lsusb. It shows like this:

Bus 002 Device 004: ID 19d2:0146 ONDA Communication S.p.A.

Next, I installed usb-modeswitch and created a config file:

vi /etc/udev/rules.d/zte_mf651.rules

then filled it with:

SYSFS{idVendor}=="19d2", SYSFS{idProduct}=="0146", RUN+="/usr/bin/eject %k", OPTIONS+="last_rule"

Now my modem is detected, dmesg shows ttyACM0 and ttyACM1.

After configuring My Provider, it shows on the top menu bar, under the network connection icon. When I clicked it, the modem was connected, but there seems no internet connection.. it can't access internet via browser. While it works fine on windows.

So, How to enable/optimize the internet connection? Is there any specific driver for this device on Ubuntu? Any solution would be appreciated.

share|improve this question
Does your modem support Ethernet ports. If yes, can you please try with that and let us know. – Abhijeet Dec 27 '11 at 10:10
how to check that my modem support eth port? – Hiro Dec 28 '11 at 7:03
I hope you can recognize RJ45 female pin, if not then search for it in google and see how does it looks. Then check the back side of your modem for similar port. If it is there then your modem supports eth port. – Abhijeet Jan 7 '12 at 5:50
oops, it seems my modem doesn't support eth port.. it's just a simple usb dongle type modem – Hiro Jan 10 '12 at 6:13

This is a bug in ModemManager. You should manually start DHCP client AFTER connection with NetworkManager, just type in the command prompt:

sudo dhclient usb0

Instead of UDEV rules you can use usb_modeswitch utility, see this thread:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.