Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using a Dell Inspiron e1505 laptop. I can connect with a wired connection but it doesn't pick up the wifi or I cant enable it at all. It's rather frustrating. Any help?

share|improve this question
    
Please look at this question and add some hardware information and logs etc to your question. Thanks. askubuntu.com/questions/14008/… –  fossfreedom Dec 27 '11 at 22:48
add comment

4 Answers

Have you tried System Settings -> Additional Drivers?

Try that but, I've noticed an odd bug when installing Ubuntu in PC's Using Broadcom, before Install you must check if Wifi works normally, if is not that way you should check System Settings -> Additional Drivers and enable them before proceeding the Installation. If you not do this, when you try to install the additional drivers after ubuntu installation they are never detected properly.

share|improve this answer
add comment

Check Network Manager - does it have an Enable Wireless entry? If so, ensure that it's checked. If not, then the driver for your wireless device probably hasn't been loaded. Do lspci -k -vv | grep -A11 -i wlan (adjust the -A11 to ensure you see all the lines following wlan, e.g. -A12, -A25), and find out what your system knows about your wireless interface.

share|improve this answer
add comment

I faced the same problem. I found the solution and I put it in this website :) Please try to do the steps in this link step-by-step. Finally, the solution for slow wireless (WiFi) on both Ubuntu 11.10 & 12.04

share|improve this answer
add comment

This is the actual steps to follow, some times wifi card may block.

Check if the wifi card is blocked (Terminal)

rfkill list wlan     (for wifi)

OR

rfkill list all             (for wifi and bluetooth)

UNBLOCK:

rfkill unblock wlan     (for wifi)

OR

rfkill unblock all             (for wifi and bluetooth)

Restart the network:

sudo service network-manager restart

I got the same problem to my laptop the above step does't work for me unfortunately this worked for me try this if the above does't work for you.

Actually I followed 2 step to enable wireless in my PC

Step 1 : Removed the bcmwl-kernel-source package

sudo apt-get remove bcmwl-kernel-source

Step 2 : Installed the firmware-b43-installer package.

sudo apt-get install firmware-b43-installer

And then rebooted my PC .

Finally got my work done. :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.