Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Web browsing slow randomly since doing a clean load of 11.10. Using an HP Pavillion dv6000. Tried firefox, chromium, unity, unity 2d, gnome. No difference. Sometimes it flies, sometimes it takes 3-5 minutes to load the google home page or any other page including yours. It always says "waiting for (google.com or whatever)"

share|improve this question

closed as too localized by Bruno Pereira Mar 10 '12 at 22:57

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
check cat/etc/resolv.conf. weather proper dns is there or not –  Deepak Rajput Dec 27 '11 at 4:40

2 Answers 2

The previous Update (1/6/11) to 11.10 seems to have resolved the problem. Both firefox and chromium now perform properly without the frequent "408 Request Time-out Your browser didn't send a complete request in time" errors.

share|improve this answer

This could be a problem with your connection. We need to know more about your connection to the web. Sounds like a problem I had with my ISP having to do with periodic packet loss. Turned out to be a hardware problem on their main line. Run speedtest.net and look for inconsistent reports.

Have you tried re-installing the browsers? The only other thing I can think of is taking a look at your network interface driver. Perhaps someone else could jump in with a suggestion.

share|improve this answer
    
"408 Request Time-out Your browser didn't send a complete request in time." This is what I got when I tried to add this comment a few minutes ago. It took about 4 minutes to come up. This looks like the browser is not requesting the page to me. It's not a connection issue. My other computer running 10.4 is what I use when I can't use this one. It has no problem. –  Terry Jan 1 '12 at 8:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.