Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem with my fresh instalation of Ubuntu 11.10. The problem happen when i start up my browser and accessing website such google, askubuntu.com, facebook and other sites. frustate on the situation i try watch the progress in system monitor. the result from monitor shows that there is no data transfer when i try to accessing the page. firstly, i assume that it is the trouble from my ISP or my home connection. But it is not. When i try pinging google it shows transaction between my computer and the network but still null from browser. Then i tried to test the aptitude and it was work fine but still the browser won't recieve any packet from the internet.

Here is the detail of my tools :

  1. Laptop : Toshiba Satellite e205 (network card atheros)
  2. Operating System : Ubuntu 11.04 dual booted with Win7
  3. Browser : Mozilla Firefox comes up with the Ubuntu 11.10 installation
  4. Chrome : Last version (just yesterday install it)

Thank You before :)

[this question posted via win]

share|improve this question
    
please name which browser u r using –  Deepak Rajput Dec 27 '11 at 3:10
    
Yes, It would help to know what browser you are using, and maybe what plugins it has, a plugin may cause this or anything like that, –  Micheal Harker Dec 28 '11 at 14:02
    
Have you tried different browsers? Does wget a page work? Do you have a slow connection or not connection at all from your browser? –  César Dec 28 '11 at 14:42
    
i'am using default browser in ubuntu. Mozilla Firefox. i had also try the up to dated chrome from google yesterday. i though it may come up with the Atheros brand. hmm... i might make some screencast to make sure of it. –  Arif Setyawan Dec 30 '11 at 9:32
    
1. Try connecting using an ethernet cable. Does it work? 2. We need more information: a) Router brand & model number b) Output of commands lspci -nn and lsusb (edit your question and add them) 3. Are you using a proxy or a firewall? 4. Were you downloading any torrents lately? 5. Search for program "Additional drivers" in unity. See if you have any recommended drivers to install. –  medigeek Dec 30 '11 at 9:50

1 Answer 1

up vote 0 down vote accepted

Search for program "network connections" in unity (or run nm-connection-editor in terminal). Select your connection and click edit.

  1. Set MTU instead of automatic to be something less than 1500 (e.g. try: 1460, 1470, 1480, 1490). Note: You can reset it back to automatic if you set it as 0.

  2. Set IPv6 Method to "Ignored".

Click Save.

Then restart your router and restart your computer for settings to take effect. (Or disconnect/reconnect to your connection from the indicator tray icon)

If none of the MTU values help, see the 2 comments I wrote above.

share|improve this answer
    
thanks for the answer. it is very helpful. but anyway, how'd you find the solution like that? so in the future i may figure it out before further asking to the forum. gracias.. :) –  Arif Setyawan Jan 16 '12 at 12:46
    
I had the same problem with a router I bought (TP-Link w8960n). I bet it's the MTU that was the problem. I don't know much about MTU size, but I know that it is a packet size, the bigger it is, the more chances you have to have problems with "some" websites. The transfer of packets can sometimes choke a modem (especially the ones with enabled Firewall and SPI Firewall), so using MTU from 1440 up to 1480 is recommended. All you need to do is test which one is better for your connection. –  medigeek Jan 20 '12 at 0:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.