Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have managed to get 3D acceleration to work when running Ubuntu 11,10 in virtualbox, however, when Ubuntu loads the unity display, any application I launch seems to be hidden.

The open apps are running, but not being displayed.

All works fine when in 2D, so it is something to do with the 3D acceleration.

Wondered if anyone had the same issue...

  • Host: OS x Lion
  • Guest: Ubuntu 11.10

When I resize the virtualbox window, the applications flashes on to the screen, but then disappears again.

When I right click, I can create a document, the icon is shown on the desktop, but when I open it, again it is there but does not display.

Additional:

  • Virtualbox settings:

    • Video Memory: 128MB
    • 3D Acceleration Enabled
    • Base Memory 1512MB
    • 1CPU (uncapped)
    • VirtualBox Version 4.1.8 r75467
  • Installed on Guest:

    • xserver-xorg-video-intel
    • xserver-xorg-video-vmware
    • VIRTUALBOX-GUEST-DKMS
    • VIRTUALBOX-GUEST-UTILS
    • VIRTUALBOX-GUEST-X11 -VIRTUALBOX-OSE-GUEST-X11
    • ALL VERSIONS 4.1.2-DSFG-1UBUNTU1
  • Host info:

    • Processor 2.53 GHz Intel Core i5
    • Memory 8 GB 1067 MHz DDR3
    • Graphics NVIDIA GeForce GT 330M 512 MB
    • Software Mac OS X Lion 10.7.2 (11C74)
    • Extension Pack: Oracle_VM_VirtualBox_Extension_Pack-4.1.8-75467.vbox-extpack

Unity 3D displays ok, but when any program is opened it is not displayed, however is running, as though it is behind the desktop. If i resize the virtualbox window the running program flashes on the screen and then disappears again

If I right click on the desktop after opening a program, eg Nautilus, the nautilus right click menu appears. So the program is there, and operational, but is not being displayed.

Has anyone got Unity working in Virtualbox or VMWare Fusion, if so what versions of Virtual** software?

Reported bug here: https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/909534

share|improve this question

closed as too localized by fossfreedom Jun 27 '12 at 19:59

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
can you provide your virtualbox setting? –  shantanu Dec 26 '11 at 18:48
    
Video Memory: 128MB, 3D Acceleration Enabled, Base Memory 1512MB, 1CPU (uncapped) –  pst007x Dec 28 '11 at 18:51
    
VirtualBox Version 4.1.8 r75467 –  pst007x Dec 28 '11 at 18:55
    
On guest: xserver-xorg-video-intel and xserver-xorg-video-vmware –  pst007x Dec 28 '11 at 18:58
    
However, Guest sys info GRAPHICS: UNKNOWN –  pst007x Dec 28 '11 at 18:59
show 8 more comments

2 Answers 2

up vote 1 down vote accepted

I reported the bug here: Reported bug here: https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/909534

share|improve this answer
add comment

Do you happen to be using multiple monitors? If so, I wonder if Unity thinks you have a desktop that's larger than your physical display and then placing apps off-screen.

Try this:

  • In VirtualBox, with the VM powered off, go to Settings > Displays > Monitor Count. Make sure it's 1.

  • Once powered on, select the power logo in the upper right of the Unity menu bar. Select Displays. Make sure it also shows only one monitor.

This is a wild guess (the bounty made me do it!).

share|improve this answer
    
Only one monitor... –  pst007x Jan 5 '12 at 13:23
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.