Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have ubuntu 11.10 and when I run any package management command in terminal I get this message

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a'
to correct the problem. 

What is the problem and how can I solve it?

share|improve this question
1  
Welcome to Ask Ubuntu!) It's never safe to publish your email address on an open web site. I've removed it from the post. If you're sure you want it to be publicly visible, you can undo this revision. Note that askubuntu.com can automatically inform you of answers to your question. More information on this can be found here –  lumbric Dec 26 '11 at 16:53

1 Answer 1

up vote 5 down vote accepted

The error message usually points to having interrupted a download in the past.

This should be resolved by the following:

sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get update && sudo apt-get upgrade
share|improve this answer
    
yes but i don't remember what i was installing then i cancel it –  Ax3 Dec 26 '11 at 17:22
    
doesnt really matter - just copy and paste the commands above and it should resolve your package installation issues. –  fossfreedom Dec 26 '11 at 17:24
    
yes . thank u , problem solved by u ,,,,, thank u again –  Ax3 Dec 26 '11 at 17:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.