Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try yo install php5 using

sudo aptitude install php5

I get the following error.

The following packages have unmet dependencies:
  apache2-mpm-worker: Conflicts: apache2-mpm which is a virtual package.
  apache2-mpm-prefork: Conflicts: apache2-mpm which is a virtual package.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
The following actions will resolve these dependencies:

      Remove the following packages:                                    
1)      apache2-mpm-worker                                              
2)      flashplugin-downloader                                          
3)      flashplugin-installer                                           
4)      libasound2                                                      
5)      libasound2-plugins                                              
6)      libasyncns0                                                     
7)      libatk1.0-0                                                     
8)      libavahi-client3                                                
9)      libavahi-common3                                                
10)     libc6                                                           
11)     libcairo2                                                       
12)     libcomerr2                                                      
13)     libcups2                                                        
14)     libcurl3                                                        
15)     libdatrie1                                                      
16)     libdb5.1                                                        
17)     libdbus-1-3                                                     
18)     libexpat1                                                       
19)     libffi6                                                         
20)     libflac8                                                        
21)     libfontconfig1                                                  
22)     libfreetype6                                                    
23)     libgcc1                                                         
24)     libgcrypt11                                                     
25)     libgdk-pixbuf2.0-0                                              
26)     libglib2.0-0                                                    
27)     libgnutls26                                                     
28)     libgpg-error0                                                   
29)     libgssapi-krb5-2                                                
30)     libgtk2.0-0                                                     
31)     libice6                                                         
32)     libidn11                                                        
33)     libjack-jackd2-0                                                
34)     libjasper1                                                      
35)     libjpeg62                                                       
36)     libjson0                                                        
37)     libk5crypto3                                                    
38)     libkeyutils1                                                    
39)     libkrb5-3                                                       
40)     libkrb5support0                                                 
41)     libldap-2.4-2                                                   
42)     libnspr4                                                        
43)     libnspr4-0d                                                     
44)     libnss3                                                         
45)     libnss3-1d                                                      
46)     libogg0                                                         
47)     libpango1.0-0                                                   
48)     libpcre3                                                        
49)     libpixman-1-0                                                   
50)     libpng12-0                                                      
51)     libpulse0                                                       
52)     librtmp0                                                        
53)     libsamplerate0                                                  
54)     libsasl2-2                                                      
55)     libsasl2-modules                                                
56)     libselinux1                                                     
57)     libsm6                                                          
58)     libsndfile1                                                     
59)     libspeexdsp1                                                    
60)     libsqlite3-0                                                    
61)     libssl1.0.0                                                     
62)     libstdc++6                                                      
63)     libtasn1-3                                                      
64)     libthai0                                                        
65)     libtiff4                                                        
66)     libuuid1                                                        
67)     libvorbis0a                                                     
68)     libvorbisenc2                                                   
69)     libwrap0                                                        
70)     libx11-6                                                        
71)     libxau6                                                         
72)     libxcb-render0                                                  
73)     libxcb-shm0                                                     
74)     libxcb1                                                         
75)     libxcomposite1                                                  
76)     libxcursor1                                                     
77)     libxdamage1                                                     
78)     libxdmcp6                                                       
79)     libxext6                                                        
80)     libxfixes3                                                      
81)     libxft2                                                         
82)     libxi6                                                          
83)     libxinerama1                                                    
84)     libxrandr2                                                      
85)     libxrender1                                                     
86)     libxt6                                                          
87)     nspluginviewer                                                  
88)     nspluginwrapper                                                 
89)     zlib1g                                                          

      Leave the following dependencies unresolved:                      
90)     ubuntu-restricted-addons recommends flashplugin-installer       
91)     flashplugin-downloader recommends libasound2-plugins (>= 1.0.16)

How do I resolve it?

share|improve this question

2 Answers 2

I can confirm that, but apt-get do not show the same warning, so use that, if you can accept that it removes apache2-mpm-worker.

share|improve this answer
    
yes it gives me an option to accept but when I do that it screws with other packages. Anyhow, I got it working using tasksel. –  Ankit Dec 26 '11 at 10:16
up vote 1 down vote accepted

ok, now this is embarrassing. I am answering my own question :(

As accepting the suggestion screws my other packages. I found a cleaner way to do that.

Here is what I did

  1. Uinstalled my apache completely using sudo apt-get remove --purge apache2
  2. Restarted the computer (no reason, just felt like it, i am not sure if it had any effects)
  3. installed tasksel. sudo apt-get install tasksel
  4. then sudo tasksel install lamp-server
  5. Done!
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.