Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a new Xubuntu user. Earlier when using Gnome, I was able to configure several desktop shortcuts, particularly for navigation between workspaces.

But, now in Xubuntu, I cannot find those options.

Where can I find those options.

share|improve this question

5 Answers 5

up vote 23 down vote accepted

Keyboard shortcuts are tucked away in your Settings Manager - Window Manager - Keyboard

enter image description here

Scroll down the list - you will see several workspace shortcuts, some defined with a shortcut and some awaiting to be defined.

share|improve this answer

There are more available in Settings Editor in Settngs Manager, which can be launched from the command-line using:

xfce4-settings-editor

This will display:

XFCE4 Settings Editor

share|improve this answer
    
I tried changing my left_workspace_key to <Super>Left using the editor with sudo. Restarted and the shorcuts remain bound to <Control><Alt>Left any help? en.zimagez.com/zimage/screenshot-10252014-012914pm.php –  Harry Moreno Oct 25 at 20:32

For Xfce 4.8 (Xubuntu 12.04 LTS)

Keyboard shortcuts are accessible from Settings -> Settings Manager -> Keyboard -> Application Shortcuts:

enter image description here

  • Choose "Add" to add a command you need to assign to a shortcut.
    enter image description here

  • In the window following "Ok" press the key combination you want to assign:
    enter image description here

share|improve this answer
    
What would I add here to make <Super> open the Application Menu? –  Eyal Apr 21 '13 at 20:24

If you would like to do such on several machines without having to open windows, you can use the very handy xfconf-query command in a bash script to --set a --property in xfce4-keyboard-shortcuts.xml.

Here is an example:

$ xfconf-query --create --channel xfce4-keyboard-shortcuts --property /commands/custom/XF86AudioMute --type string --set 'amixer -D pulse set Master 1+ toggle'

As a matter of fact, this part of my solution to restore the function of the mute button in Xubuntu 12.04.

share|improve this answer

You can also play in a console with gedit and /apps/metacity/keybinding_commands or /apps/metacity/global_keybindings

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.