Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was using a "ZTE" 3G Mobile Broadband to connect with the Internet. It had some hardware issues, and I bought a new "Prolink" 3G Mobile Broadband. When I try to connect it, Ubuntu shows a "Network Disconnected" message.(Then the device turns off)

How ever I found a temporary solution.

I ran the following command on Terminal,

 sudo killall modem-manager

Then I unplugged the Mobile Broadband device, and plugged it again. Few seconds later, I successfully connected to the Internet from Network Manager.

Now I have to do this every time Ubuntu starts.

(I tried a command in a forum (which I cannot remember) to view the current Network device. It showed the detail of my OLD mobile broadband. )

share|improve this question

closed as too localized by jrg Dec 30 '12 at 1:45

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.