Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Acer Aspire 6930 with an Intel 5100 WiFi chip set. The wireless worked in Windows 7, but my wife has an unparalleled mastery of finding malware in Windows, so to make things a bit easier on myself, I decided to set up Ubuntu for her.

Problem is, now the wireless is busted...wired network works flawlessly.

I can scan networks just fine, pick up all of them that I would expect to see in the neighborhood, but can't connect to anything.

Error message when trying to connect switches back and forth between "Bad Password" and "Can't obtain IP Address" errors. I've double checked the password is correct, still spits that error from time to time. Used another machine to setup an ad-hoc network, with no password, and it gives the "Can't obtain IP Address" error all the time when trying to connect to that.

The other interesting thing I noticed was that trying to enable the computer into an ad-hoc hot spot doesn't work either (Via System Settings >> Wireless >> Use as Hot Spot). It will show the hot spot information briefly, but as soon as I refresh my network list on another machine, to try to connect, the screen goes back to the default showing what network (none) I'm connected to.

Any ideas?

share|improve this question
    
Possibly related:askubuntu.com/questions/66810/… –  mikewhatever Dec 26 '11 at 9:59
    
try the command: rfkill list Then add the output into your question. –  jaorizabal Mar 14 '12 at 22:03
add comment

2 Answers

https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsIntel says the Intel 5100 chipset works using the iwlagn driver, "This driver worked out of the box on a default (desktop) install of Ubuntu 10.04 and 10.10 using WPA and WEP and open networks."

sudo modprobe iwlagn should load the correct driver. Then do dmesg | tail -n 50 | more (for various values of "50") and see what the iwlagn driver logged.

Then, try to connect to a wireless network - ensure that you're authorized, that you're using the same type of encryption, and that, yes, the password is correct, even UPPER and lower case. If the connection fails, do ls -rlt /var/log and look at the last several log files (the most recently modified ones), the last several lines of each will contain helpful information.

share|improve this answer
add comment

Try downloading the correct Unix drivers for that wireless card. I have a similar problem with my Atheros wireless card in my notebook, which also has problems on Windows -- it can scan but can't connect even to open wireless networks.
Try downloading the drivers and firing up a sudo root terminal to install them. Look on the notebook manufacturer website; if not there, try a google search for Unix or Linux drivers for that card. If all else fails, try assigning an IP address from outside of the router's DHCP pool, and adding the default gateway manually, then see if you can connect from there.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.