Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After deleting old Linux partitions in order to free space on hard disk, I got an error from GRUB:

error: no such partition

And then I saw a grub rescue> prompt. After googling around I found that in order to boot normally I have to type the following commands.

set prefix=(hd0,msdos5)/boot/grub
set root=(hd0,msdos5)
insmod /boot/grub/linux.mod
linux /vmlinuz root=/dev/sda5 ro
initrd /initrd.img

Here is the boot info summary report created by Boot-Repair.

However, on each reboot I have to type this again. How can I tell to GRUB once and all what configuration file to use?

share|improve this question
I have the exact same problem, however when I try to use insmod I'm prompted with error: unknown filesystem.. When I ls I'm presented with (hd0) (hd0,msdos2) (hd0,msdos1). I've tried setting either of these as prefix and then root but whenever I try to insmod I'm prompted with the same error: unknown filesystem.. What can I do? – piperchester May 8 '13 at 17:02
@PolyShell I think you better ask this as a separate question. – jutky May 8 '13 at 19:47
up vote 6 down vote accepted

Try these commands

sudo update-grub
sudo grub-install /dev/sda

If you want a graphical option, try boot-repair

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update
sudo apt-get install -y boot-repair && boot-repair

enter image description here

share|improve this answer
Thanks a lot. Previously I was running Boot-Repair from a liveCD and it didn't helped, and after I've found what commands to type in grub rescue I haven't tried it once again. Thanks again. – jutky Dec 26 '11 at 0:28
It worked exactly like advertised when I tried it (installing and using boot-repair). This was on an Acer netbook where I had chosen a wrong item in the GRUB menu, "Windows Recovery Environment (loader) (on /dev/sda1)", during boot time. – Peter Mortensen Jun 19 at 12:02

Did you run update-grub to update /boot/grub/grub.cfg?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.