Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm currently investigating what makes my Dell Studio 1558 so slow sometimes.

I noticed that it was getting really hot, and started checking temperature. It seems that my GPU (AMD Radeon HD 5470) is getting really really hot (even on a laptop stand). While standing on a desk, it easily gets to 80°C (176°F)

I'm using the fglrx version that came with Ubuntu 11.10, the Catalyst 11.8 driver.

So, my questions now are:

  • What are the risks of an overheated GPU?
  • Does an overheated GPU cause my laptop to slow down?
  • Can I fix this?

Extra info:

I tried installing Catalyst 11.12 manually, but it kept on saying it found an older installation (sudo apt-get purge fglrx* was not enough it seemed).

In "Additional Drivers", I am not able to install the post-release version of fglrx

When I remove fglrx, I only get a black screen at boot

Hardware:

Dell Studio 1558 - i5 CPU @ 2,40 GHz - 8GB DDR3 memory - AMD HD 5470

share|improve this question
    
set your fan to 100% permanently until the issue is resolved –  hbdgaf Dec 25 '11 at 23:12

2 Answers 2

I found my answer.

I was suffering from this bug: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/803943

Temporary fix is using the PPA of Daniel van Vugt: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/803943/comments/53

When the patch is accepted, it will be fixed in the standard updates.

My CPU usage for compiz dropped from 40% to 5% when idle

My GPU temp lowered from 75°C to 50°C when idle, from 100°C to 75°C when stressed. A huge improvement!

share|improve this answer

I had a similar problem with my video card. I have an ATI Radeon HD 3200 running with an AMD Turion. When I was using Ubuntu 11.10 32 bits it was reaching 90ºC! I tried many different things but none of them worked. So, almost giving up, I changed the Ubuntu 11.10 32 bits for the 64 bits version. Now it reaches at most 80º. If you have an AMD processor and you are using the 32 bits version I think it's interesting to try using the 64 bits version. = )

share|improve this answer
    
Thanks for your suggestion! However, I am already running 64-bit version of Ubuntu. I also narrowed it down to a bug in compiz (unity plug-in). It might work for you too. Or use gnome-shell –  Ruben Dec 26 '11 at 18:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.