Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a desktop PC and a notebook in the same network. Each of them is running Ubuntu 11.10. I shared a folder on my notebook which I somehow can not access by my PC.

Here is what I did so far:

On the notebook I right clicked on my home folder and went to

Properties -> Share

where I marked Share this folder and Allow others to create and delete files in this folder. It asked me for installing some services. They failed. So I did manually sudo apt-get install samba. Worked fine. Now I went to my PC an opened my home folder. Above in the menu I selected GO->Network. There I pressed CTRL+L and entered the local ip address from my notebook. But somehow it can't find it.

Is there more configuration, that I have to do?

I appreciate every help, thanks!

PS: Sometimes it says

Error: Failed to retrieve share list from server
Please select another viewer and try again.

I refer to this picture in one of the comments below. It is not directly related to the formulation of my initial question but to a solution presented below by @lumbric in the comments.

enter image description here

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

CTRL+L in Nautilus (that's the name of Ubuntu's default file browser) was a good start! But you have to use the correct network protcoll which is smb when using Samba. So you have to enter:

smb://127.0.0.1/

(of course replace the IP address)

This might be quite a serious usuability bug in Ubuntu. If you just click on "network" it never finds any computer in your network.

Additional tipps

I'm not sure wether SMB is the best joice for a home network if both machines are running Ubuntu. Samba is primarily used in order share files with windows computers. But I haven't any better suggestions. sFTP and SSH is good but slow. NFS is lacking some important features as far as I remember. FTP might be a joice.

PS: Btw note that STRG is german and english speaking users might not understand that this is the CTRL key... ;)

share|improve this answer
    
Thanks for the detailed answer. I tried smb://ip_of_laptop but now it keeps saying Error: Failed to retrieve share list from server. Please select another viewer and try again. I googled and find that the workgroup could be different. Any idea how to solve that? Thanks! –  Aufwind Dec 25 '11 at 18:44
    
PS: I replaced STRG by CTRL. "Danke" for pointing that out. ;-) –  Aufwind Dec 25 '11 at 18:45
    
I just wanted to edit my answer and to add that my answer probably won't help you. The error message you mentioned before already doesn't fit with what I thought was the problem. Can you access the share from the desktop computer? Use smb://127.0.0.1/ to try it out. –  lumbric Dec 25 '11 at 18:56
    
Yes, smb://127.0.0.1/ works fine now. A reboot seemed to solve (almost) all problems. Now I can access the Notebook by SSH and by smb://192.168.0.*. But the latter asks me for a password and then revokes the correct password. It wants a workgroup entry too which is WORKGROUP by default. If you have a hint why it does not want to take my credentials it would be nice. But since ssh works there is no priority anymore to solve this except for another user running into the same issue. Thanks in advance for our effort so far. –  Aufwind Dec 25 '11 at 19:20
    
Samba passwords and system passwords do not match necessarily. Try out smbpasswd! –  lumbric Dec 25 '11 at 19:27
show 3 more comments

Re-creating the share on your notebook (as you first tried to do) after installing samba may solve your problem. Already happened to me. Tell me if this works to update my answer.

Using sshfs to share folders:

If you want to share folders between Ubuntu computers, may I suggest to use a native Linux solution ? Samba re-implements windows protocols and i always ended up having issues with the samba configuration. On the other hand I found sshfs much easier to use. Assuming you have sshfs installed and you're a user of the fuse group, just do the following:

mkdir ~/shared_folder
sshfs <user>@<ip>:<shared_folder_path> /home/$USER/shared_folder

Then check it works and do your stuff:

cd ~/shared_folder
ls
nautilus .
etc.

To unmount:

fusermount -u ~/shared_folder

Adding an entry to /etc/fstab:

Some people prefer to add this line at the end of the /etc/fstab file:

sshfs#<user>@<ip>:<shared_folder_path> <mount_point> fuse defaults,user,idmap=user,noauto 0 0

By doing so, you'll be able to mount the folder with mount ~/shared_folder. Still unmount with fusermount.

I'm not usually using this method as i configured my key to browse my bash history so that just typing sshf+ gives me all my previous sshfs mounts. Also, I don't need to do system-wide changes.

share|improve this answer
    
Thank you very much. It's always good to know an alternative way of doing things - or in this case the native way. –  Aufwind Dec 25 '11 at 21:48
    
You're welcome :) If you found my answer useful, upvote it ^^ –  Maxime R. Dec 25 '11 at 22:49
    
SSH will be significantly slower than SMB or other protocols. If want to use Gigabit ethernet to backup a large harddisc you don't want to use SSH. –  lumbric Dec 25 '11 at 22:53
    
I won't disagree prokop.uek.krakow.pl/projects/fs_benchmark.html ^^ I like how it's easier to use, considering i use sshfs to temporarily access some files on another computer. Sure enough, for a more permanent share, samba or nfs may be more suited to the case. Any clue about what features nfs lacks for ? –  Maxime R. Dec 25 '11 at 23:41
    
+1 Deserved upvote provided. :-) –  Aufwind Dec 26 '11 at 3:39
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.