Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am setting up a laptop for a friend with Ubuntu 10.10. I turned on fancy visual effects and the "desktop cube" plugin as well. When I rotate the cube every window and even the wallpaper gets dark and desaturated. I tried looking into other plugins, even turning them off, other Gnome options, and I couldn't figure out why this fading happens. I've set up various computers with Ubuntu before but I have never seen such a problem.

How could I turn the fading off and keep the visual effects?

share|improve this question
1  
when you say fading or gets dark are you referring to the windows not responding? –  jnut Oct 25 '10 at 17:34
1  
That sounds like the default way for Ubuntu to display an application isn't responding (when visual effects are activated). Rotating the cube might be taking enough resources on your computer that it's causing all the running applications to freeze up while waiting for resources to be available. –  Firefeather Oct 26 '10 at 14:19
1  
I think the plugin that controls this is the Fade plugin. You'll need the Compiz Settings Manager to set the delay for fading to a longer period. –  Firefeather Oct 26 '10 at 14:23
    
I know that darkening is the default for non-responsive windows, but that never happened with the desktop wallpaper. I'll check the Fade plugin the next time I meet my friend, and see if it settles the problem. –  bandi Oct 27 '10 at 6:58

2 Answers 2

Uncheck General Options -> Display Settings -> Lighting & you're good to go! I'm just setting up my own 10.10 box & found the same problem. Apparently it doesn't annoy some people. Go figure.

share|improve this answer

If you have ADD helper enabled in your compiz-config, disable it. I'm guessing that is the one, because it fits the description well, and I've seen it do that before. Look to this great guide for more in depth information.

Try adding | !Class=Nautilus) or & !(Class=Nautilus) to the Fading windows plugin to disable the desktop fading, but as for the other windows, I'm still not sure what is causing it.

share|improve this answer
    
I don't see an "Add Helper" module. Which module do you mean? –  Kees Cook Nov 7 '10 at 18:37
    
updated my answer, btw, that's exactly what it's called. –  RolandiXor Nov 7 '10 at 18:56
    
unfortunately changing it did not help with the problem :-/ The fading occurs only when I rotate the cube. –  bandi Nov 7 '10 at 20:37
    
there are only two plugins that introduce this function (as far as I know, and the window fade plugin should not cause this issue, but I'll keep looking for a solution). –  RolandiXor Nov 7 '10 at 22:11
    
Is this only for mouse rotate or keyboard too? Can you upload your CompizConfig preferences so others can try them. –  Adam Nov 8 '10 at 15:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.