Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've already tried all possible ( solutions, no progress. I'm in despair. In Windows (on the same machine) this adapter works stably.

Device: Trendnet TEW-649UB.

System details: Ubuntu 11.10;

leventov@leventov-ubuntu:~$ uname -a
Linux leventov-ubuntu 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
leventov@leventov-ubuntu:~$ lsusb
Bus 002 Device 002: ID 0bda:8172 Realtek Semiconductor Corp. RTL8191S WLAN Adapter
leventov@leventov-ubuntu:~$ dmesg | grep 8712 #current driver
[    8.146510] r8712u: module is from the staging directory, the quality is unknown, you have been warned.
[    8.147113] r8712u: DriverVersion: v7_0.20100831
[    8.147124] r8712u: register rtl8712_netdev_ops to netdev_ops
[    8.147127] r8712u: USB_SPEED_HIGH with 4 endpoints
[    8.147478] r8712u: Boot from EFUSE: Autoload OK
[    8.551272] r8712u: CustomerID = 0x0000
[    8.551275] r8712u: MAC Address from efuse = 00:14:d1:6c:52:19
[    8.551625] usbcore: registered new interface driver r8712u
[    9.501351] r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"
[   10.160471] r8712u: 1 RCR=0x153f00e
[   10.161241] r8712u: 2 RCR=0x553f00e
leventov@leventov-ubuntu:~$ lsmod | grep 8712
r8712u                189049  0 t

Update. The problem remains in Ubuntu 12.04, 12.10, 13.04, 13.10 and 14.04 (with respective ndiswrapper updates). Ridiculous.

share|improve this question

I am not sure there is a solution to this problem. I was googling for this exact same issue with my dongle and I have seen people struggle with the firmware being missing. Either that or a new driver solved this problem for most.

This morning I bought a new Billion Wifi Dongle, that uses the exact same chipset, and driver, but it works under Ubuntu 11.10. Perhaps in our case it is just badly behaved hardware, that somehow works with the windows drivers?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.