Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently installed the Realtek High Definition Audio Driver package using the Terminal.

Before installing the software the sound was working fine but my sound sytem is 5.1 Creative. Out five speakers only two speakers were working. Earlier when I am using windows I needed to install the realtek audio driver in order the 5 speakers to work.

I followed the instructions given in the installation file during installation. The last step of the instructions states that the machine shall be rebooted to finish the installation. After, rebooting ALSA mixer control is to be edited (which are by default set to mute).

My problem is I cannot find that ALSA mixer in computer.

When I type alsamixer in terminal I am getting the following message :

Cannot open mixer: No such file or directory

I can confirm I have done sudo apt-get install alsa-utils and alsamixer is installed.

Please suggest how can I rectify this problem.

Following is my Audio Device

Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)

and Regarding the Instructions : Following are the Instructions given by the software provider i.e., Realtek

  1. unzip source code tar xfvj alsa-driver-1.0.xx.tar.bz2
  2. Complied source code a. cd alsa-driver-1.0.xx b. ./configure --with-cards=hda-intel c. make d. make install
  3. reboot your machine
  4. Use the alsamixer the disable mute (All audio line default is mute) Must to compile and to install the ALSA library and utility. (Use automatic install is already install) excute alsamixer

I have followed all the instructions upto Step 3 but I was unable to do the Step 4.

I am using Ubuntu 11.10 version.

Thanks in advance.

share|improve this question

2 Answers 2

The command line alsa mixer can be found by installing package alsa-utils in the Ubuntu Software Center and running the command alsamixer in a terminal window.

Alsa-utils are in the hidden items of the Software Center. If you prefer a GUI version you can install GNOME ALSA Mixer.

share|improve this answer

console

  • open a terminal
  • type: alsamixer

GUI

  • Install gnome-alsamixer with the command sudo apt-get install gnome-alsamixer
  • Either type gnome-alsamixer in a console or open it in the applications menu.

Pulseaudio

pulseaudio volume control has the command pavucontrol in there you can do the same things as in alsamixer. If pulseaudio is installed. To install it type: sudo apt-get install pulseaudio.

share|improve this answer
    
Thanks for the reply.The Installation of gnome-alsamixer was successful but when I start the application the GUI does not show any control. It is just a blank window. Can you please help me. –  Srinivas Dec 25 '11 at 22:40
    
@srinivas what is shown in the console window? are there any error messages or similar? I mean if you open the GUI version by typing gnome-alsamixer in a terminal? –  Alvar Dec 26 '11 at 0:10
    
I didn't find error messages or something. I am getting blank window opened when start that gnome-alsamixer via Terminal as well as the program launcher. I have install the Pulseaudio also now. All these settings windows are showing a 'dummy output' in the output tab. I am unable to find my hardware device. Kindly suggest me what shall be done. –  Srinivas Dec 26 '11 at 2:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.