Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to set up my old desktop as a wireless router. However after following the instructions found on, my computer doesn't seem to be broadcasting, and my other computer is not able to see the network it is supposed to be making.

No error messages or anything have come up, and nothing seems to be wrong except for the fact that it's not working. At this point, Google is just taking me in circles, so any help anyone can give me would be greatly appreciated.

Pertinent details:

Ubuntu version=11.10 (Server version)

Wireless adapter=Rosewill RNX-N180UBE

Driver installed=r8712u - Note that this driver does not support nl80211, so certain tools including hostapd and iw are not available.

Wlan section of /etc/network/interfaces:

# Wireless network
auto wlan0
iface wlan0 inet static
    wireless-mode master
    wireless-essid "llamamall"
    wireless-channel 1

Output of ifconfig (trimmed to just wlan0 entry):

wlan0     Link encap:Ethernet  HWaddr 00:1a:ef:1f:cc:55  
          inet addr:  Bcast:  Mask:
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Ouptut of $ iwconfig wlan0

wlan0     unassociated  Nickname:"rtl_wifi"
          Mode:Master  Access Point: Not-Associated   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Shouldn't that show an essid?

share|improve this question
Are you still looking for help or have you solved the problem? If you have found an answer please consider adding it below, thanks! – coversnail Apr 8 '12 at 16:41
Yeah, It turns out that the Linux driver does not support "Master" mode. I had to set it up to run in "Ad Hoc" mode in the end. Thanks. – vomitHatSteve Apr 9 '12 at 14:45

This question was solved by the OP:

It turns out that the Linux driver does not support "Master" mode. I had to set it up to run in "Ad Hoc" mode in the end.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.