Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

If I have an older Ubuntu release, lets say it is Ubuntu 10.04, and I have to install a package from a newer Ubuntu apt repositories (e.g. from Ubuntu 11.10 repo's) because the newer versions of that package have a feature which I require most. What is the best way of installing the package without affecting or upgrading other packages. Here is what I want to do. But the solution explained there Updates other packages which I don't require.

share|improve this question
The article you linked is too long. Can you summarize the relevant bits? – Scott Severance Dec 25 '11 at 9:07
up vote 3 down vote accepted

You didn't mention the specific package, so I can only give generalities.

If possible, the easiest thing would be to find the appropriate .deb on and install it. As long as the requisite dependencies are available in your version of Ubuntu, it'll work great.

A second, more involved option would be to rebuild the source package using your version of Ubuntu. This would resolve certain classes of dependency problems. Look into pbuilder for this.

Finally, you could try compiling the upstream version yourself, using checkinstall. This should only be a last resort, however.

One of these options will likely work for you. If they don't, then you might not have too many options, as it would mean that there are some critical dependencies that can't really be resolved without a system upgrade.

share|improve this answer

Well you are sort of stuck in that is what is meant by dependencies.

Say you have a package, foo-1.0 , and it depends on bar-1.0

And you want to upgrade to foo-2.0 , and it depends on bar-2.0

so you can not upgrade foo (reliably) without upgrading bar

If you want to install the newer package, either accept the dependencies (probably easiest) or upgrade Ubuntu.

If you think the dependencies are not accurate, best contact the maintainer of the ppa or file a bug report.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.