Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a usb wifi adapter:

Bus 001 Device 003: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter

I start it in monitor mode like this:

airmon-ng start wlan1

And it says monitor mode was enabled [supposedly in wlan1]

So I do a test:

aireplay-ng -9 wlan1

But it says it found 0 APs. I tried compat-wireless, downloaded it and then compiled. And rmmoded the rt2800 modules, then tried to insert rt2800usb.ko, and it said something about unknown symbols, or something like that.

share|improve this question
1  
Are you sure the monitor mode is not enabled in mon0? try entering the command as aireplay-ng -9 mon0. The output of airmon-ng should indicate in what interface the monitor mode was enabled – zurdo Jan 28 '12 at 18:09
    
I'm almost positive. It said "monitor mode enabled on wlan0", not mon0. It stuck out to me because I'd always have mon0 in the past [with my other zd1211rw usb wifi adapter] – Matt Jan 30 '12 at 22:04

First try to install bt5 R1 which has all the wireless drivers patched and check then with (double check if you have any AP in your range):

aireplay-ng -9 wlan1

If it displays 0 AP, then read from rt2870 and then on the forums.

Note: aircrack works for 100% on WEP but with WPA/WPA2 only with a dictionary which is a waste of time IMHO.

share|improve this answer

Goto official site, and check for your adapter. There may be some patches for it. Otherwise you won't be able to run it

http://aircrack-ng.org

http://patches.aricrack-ng.org

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.