Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For some reason I can't change my zsh prompt by typing, say, PS1="%#". I'm using the admin-suggested config on Ubuntu 11.10. Am I doing it wrong or is it a bug?

Here's the content of my ~/.zshrc:

# Set up the prompt

autoload -Uz promptinit
promptinit
prompt adam1
#PS1="`echo "$PS1" | tr Kk Ff`"
#PS2="`echo "$PS2" | tr Kk Ff`"
#PS3="`echo "$PS3" | tr Kk Ff`"
#PS4="`echo "$PS4" | tr Kk Ff`"

setopt histignorealldups sharehistory

# Use emacs keybindings even if our EDITOR is set to vi
bindkey -e

# Keep 1000 lines of history within the shell and save it to ~/.zsh_history:
HISTSIZE=1000
SAVEHIST=1000
HISTFILE=~/.zsh_history

# Use modern completion system
autoload -Uz compinit
compinit

zstyle ':completion:*' auto-description 'specify: %d'
zstyle ':completion:*' completer _expand _complete _correct _approximate
zstyle ':completion:*' format 'Completing %d'
zstyle ':completion:*' group-name ''
zstyle ':completion:*' menu select=2
eval "$(dircolors -b)"
zstyle ':completion:*:default' list-colors ${(s.:.)LS_COLORS}
zstyle ':completion:*' list-colors ''
zstyle ':completion:*' list-prompt %SAt %p: Hit TAB for more, or the character to insert%s
zstyle ':completion:*' matcher-list '' 'm:{a-z}={A-Z}' 'm:{a-zA-Z}={A-Za-z}' 'r:|[._-]=* r:|=* l:|=*'
zstyle ':completion:*' menu select=long
zstyle ':completion:*' select-prompt %SScrolling active: current selection at %p%s
zstyle ':completion:*' use-compctl false
zstyle ':completion:*' verbose true

zstyle ':completion:*:*:kill:*:processes' list-colors '=(#b) #([0-9]#)*=0=01;31'
zstyle ':completion:*:kill:*' command 'ps -u $USER -o pid,%cpu,tty,cputime,cmd'
share|improve this question
    
Please post the syntax you are using to set your prompt. –  bodhi.zazen Dec 25 '11 at 3:11

1 Answer 1

up vote 4 down vote accepted

The prompt theme resets PS1 in the precmd hook, specifically through an entry in precmd_functions. If you want to set your own prompt, don't use prompt themes at all: comment out the two lines about promptinit and the prompt adam1 line below them. If you want to use prompt themes, use their own customization capabilities. You'll have better luck with a prompt theme if you want something very fancy and one of the preexisting themes suits you, and better luck setting your own if you want a simple or highly customized prompt.

share|improve this answer
    
I'm trying to set up my own hook with precmd_functions += color_fix_precmd right after setting up the prompt, but zsh fails to recognize precmd. What am I doing wrong? UPD: nvm, I removed spaces and it worked. –  Alexei Averchenko Dec 27 '11 at 9:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.