Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed ubuntu 11.10 in my new computer, the old one (still main computer) is ubuntu 10.04. Both PCs use "Spanish LAm" keyboard layout, the only difference is that the new PC keyboard has some multimedia keys but the configs are the same and the work well each one on each PC.

But when I use synergy to use the main keyboard in the client PC (11.10), the keyboard layout seems to be the "Enlglish (US)" layout, or other but not "Spanish LAm", while settings on both PCs remain as "Spanish LAm". The other keyboard connected by cable to the client PC does work well with the spanish layout even when using synergy.

Any idea how to fix this?

share|improve this question
    
I removed 11.10 and installed 11.04, I don't have the problem with this version. –  Uoplem Dec 26 '11 at 16:59
add comment

3 Answers 3

In my case synergy seams simply to ignore actual keyboard layout but it helps if I set it after starting synergyc.

synergyc myhost
setxkbmap us -option grp:alt_shift_toggle

You will find correct values for setxkbmap arguments in file /etc/default/keyboard. Instead of us place value of XKBLAYOUT and pass value of XKBOPTIONS to -options.

You can use this simple script to do this automatically:

#!/bin/sh

. /etc/default/keyboard
synergyc $1
setxkbmap $XKBLAYOUT -option "$XKBOPTIONS" -model "$XKBMODEL" \
                     -variant "$XKBVARIANT"

Save it as mysynergyc, set correct permissions (chmod 755 mysynergyc) and then run as usual instead of synergyc.

share|improve this answer
add comment
  1. Search for "Keyboard Layout" and open it.

  2. Use the plus sign on the bottom left of the screen to add the keyboard layout "English(US)".

  3. Restart synergy

This worked for me. (Ubuntu 11.10 64-bit)

share|improve this answer
    
I have the same problem in 12.04, though with Norwegian keymap and Windows 7 on the server side. It used to work flawlessly for me in 11.10 with the same setup. The suggestion in this answer does not work for me. –  Lars Haugseth Apr 10 '12 at 19:05
add comment

I had the same problem with my Windows server / Ubuntu client configuration. At work I had the setup the other way around and it worked like a dream.

As a workaround a added an another keymap to the Ubuntu client. Then while using Synergy switched the keymap from en to de and it started working.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.