Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just installed Ubuntu 11.10 on a Dell 620 Latitude. I am new to Linux and am not very techie. I cannot see how to connect to a wireless network. For the avoidance of doubt I cannot 'see' any available networks, nor any way to search for them. There is a strong network in range - I am using it to write this from another machine.

I can make my way through:

Network Connections > Wireless (tab) > Add

I then get to a Dialog Box called: "Editing Wireless Connection 1"

After that I am lost. Nada. Clueless.

Now, I have looked for similar problems in this forum and I see some. But I don't understand the answers. Thus:

Dell Vostro 1510 can't connect to wireless--how can I fix this?

So, please can you explain how to fix this step by step as if to an idiot please?

share|improve this question
    
Please look at this Q&A - especially the wireless question. Please add some details of your hardware and your wireless card. Thanks askubuntu.com/questions/14008/… –  fossfreedom Dec 24 '11 at 14:36
add comment

5 Answers

I have a Dell Latitude D630, with the same wireless card.
We both have:

0c:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)

I have succeeded in connecting my wireless with NO security to an Apple Airport Express, and with WPA2/PSK to a DLink DIR-601 using the b43 module that comes with Ubuntu 11.10:

`$ find /lib/modules/$( uname -r ) -type f -iname 'b43.*'  
/lib/modules/3.0.0-14-generic/kernel/drivers/net/wireless/b43/b43.ko`

Here's my suggestion:

  1. Exit Network Manager.
  2. Use the Alt-F2 key combination to open a window to enter a command.
  3. Type gksudo modprobe b43 and hit Enter. Type your password in the window that pops up, to allow the modprobe b43 command, run as root to load the b43 module.
  4. Wait 10 seconds.
  5. Click on Network Manager, and ensure that Enable Wireless is checked, then exit.
  6. Wait 10 seconds.
  7. Clink on Network Manager, and you should see wireless networks.
  8. Click on the one you're authorized to connect to.
  9. Edit that connection. Consider checking the Connect Automatically box.
  10. Apple Airport Express doesn't support WPA2, but accepts configuration info as if it did. Moral: Once you're connected, Click on Network Manager, then click on Connection Information, and see what type of Security is actually in use!
share|improve this answer
add comment

Open a terminal and post the results of ifconfig, iwconfig, iwlist scan and lspci | grep wireless here... *It's supposed to be one command: "lspci | grep wireless" (the '|' sign is shift+backslash) - that should list all pci devices that have the string 'wireless' in their name and/or description.) I'm assuming your wifi card is a PCI one, and not a usb dongle. You can do a 'dmesg | grep wireless' too while you're at it.

Your wifi is reported as 0c:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01) and it doesn't say that it'd be a firmware problem... Ubuntu should recognize it. If you have access to a wired connection, try System Settings -> Additional Drivers (in 11.10) to check if your card requires proprietary drivers. Another thing you might want to try is to search for the string 'broadcom' in the repos (in terminal do apt-cache search broadcom, or via Synaptic, that might be easier and see if any package matches your card and hasn't been installed).

Another idea is to check the BIOS and/or double check that it is not turned off - on the 620 there is an Fn+don't-know-which-button combination that turns wifi on and off (on the 610 sure was). Make sure it's turned on and not disabled in the BIOS.

I did some googling, and came up with some old info - if everything else fails, you can try using ndiswrapper. Here are two links for further info:

Ubuntu forums thread

Ubuntu Wiki

Plase note, that both of these are old, and probably - and hopefully - there is a native driver for the card. I seem to remember running Ubuntu on a 620 without issues but I might be mixing it with something else.

11.10 solution

Finally, here's a recent information:

You need the firmware-b43-installer package instead of the bcmwl-kernel-source that Ubuntu installs. Install the right one with sudo apt-get install firmware-b43-installer and remove the wrong one with sudo apt-get purge bcmwl-kernel-source (you can use 'remove' instead of 'purge', it's just my habit to purge stuff that I don't use any more). You'll need a working connection, so try to get a cable for your router.

share|improve this answer
    
Thanks, that's very helpful. I'll take a close look at your instructions and get back with the outcome. Fingers crossed. –  SMM Dec 25 '11 at 1:18
    
I also have a D630 and I followed the instructions on the post before yours to remove the wrong installer package install the proper firmware-b43-installer and got my internal wireless card to work. –  user47963 Feb 25 '12 at 5:06
add comment

You have a wireless card right? 11.10 should automatically recognize wireless connections. For instance I can go any where and I never have to enter specific information in Network Connections, I just use the wi-fi drop down (fan looking thing) in the upper right hand corner by the clock. I take it though that you've done this because you cannot see any connections. Try it somewhere else - same problem? Or try manually entering the wi-fi info in the wireless tab. Use the computer you are on now to reference the required info (connection name, type etc..) Hopefully that helps. Keep tinkering and I'm sure you'll figure it out.

share|improve this answer
add comment

I got an empty dell latitude d630 with an empty HD this christmas. I installed UBUNTU 11.10 right away. After reading about all dell latitude d630 and what comes with it, i need a driver for wireless. i found somewhere that all you need is go to Dashhome in the menu and click on additional drivers--- sure enough two additional drivers show up, the driver for Broadcom STA wireless driver and NVIDIA accelerated graphics driver. All you have to do is to actvate it and if you are like me, looking for an easy fix, that's it. after downloading and installing automatically, you have to restart the ubuntu and before you restart it the available wireless ID will show up immediately. Good luck and I hope you'll get yours working.

share|improve this answer
    
BTW, i forgot to mention that all the while doing the searching in the additional drivers, my dell latitude d630 was in wired connection. thanks mike villanueva –  mike villanueva Jan 2 '12 at 3:41
add comment

Wireless Drivers need to be installed.

The following solutions works in Ubuntu 12.04 on Dell Latitude D630.

If you have an Internet connection, just run:

sudo apt-get update
sudo apt-get install firmware-b43-installer

If an internet connection is not available, you have to manually install b43-fwcutter and Broadcom's proprietary driver, please follow steps in the "Other distributions not mentioned above" section of this article.

share|improve this answer
    
You don't have to build the driver from source if you don't have an Internet connection. You can download the necessary .deb package and install it with dpkg -i or gdebi. You may want to edit your answer to incorporate information about how to do this, which you can find here in the community documentation wiki (in this section specifically). –  Eliah Kagan Jul 12 '12 at 20:23
    
yeah, I downloaded b43-fwcutter .deb package first and installed, but when I wanted to installed firmware-b43-installer_015-9_all.deb package error messages occurred. wget http://mirror2.openwrt.org/sources/broadcom-wl-5.10.56.27.3_mipsel.tar.bz2 auto executed, but you know I don't have internet connection so it failed and have to build the driver from source. –  ZachCheung Jul 12 '12 at 21:07
1  
As detailed in the community wiki, you need to install b43-fwcutter (and its dependencies), rather than firmware-b43-installer. –  Eliah Kagan Jul 12 '12 at 22:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.