Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The PC configuration is: Pentium4 Intel,DDR2 256mb Ram 533MHZ(But now I am upgrading it to 1GB)

Whenever I tried to install Ubuntu, it says "KERNEL ERROR, Try with noapic option"

So what should I do now?

Will an increase in RAM help me?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Lack of Memory (RAM)

256MB is a very low specification for Ubuntu.

Ubuntu will work with this low specification - but only if you use a lower requirement ubuntu spin such as Lubuntu v11.10.

If you have more memory available then my recommendation would be Xubuntu (v11.04 or v11.10).

If you intend to stick with 10.04 Ubuntu then probably 512MB (preferably more) would be required.

Kernel error message

As to your kernel error - some older PCs have buggy BIOS and ACPI (power management) control.

What the error message is suggesting that you boot with the kernel parameter noapic. You will need to do this both when trying to boot with the LiveCD and after you have install ubuntu.

I've grabbed a screenshot from another question I recently answered - just substitute the word persistent as shown with the word noapic

enter image description here

To display this screen, immediately when you see the purple screen with the symbol at the bottom (seen immediately after the boot sequence starts) press Esc... If you got to the "try ubuntu screen" you missed the opportunity!

When you press F6 a pop-up menu will display. Press Esc to make this menu disappear then use the keyboard arrow keys to move to the position shown in the picture.

Once you have installed Ubuntu - you will then need to temporarily boot with noapic - this is described in the linked question below.

When you have booted into your Ubuntu desktop you can fix noapic to be a permanent Grub entry - again this is described how to do it in the linked question.


Linked Question:

  1. How do I add a boot parameter?
share|improve this answer
    
I used acpi=off! –  Shishir Dec 29 '11 at 3:23
2  
fossfreedom: You helped me a lot, this shows how efficient is to use UBUNTU. Thanks for all, I am now successfully running Ubuntu! –  Shishir Dec 29 '11 at 3:28
add comment

Same error here it seems to be a bug in kernel 3.0 . Just goto your bios and disable hyper threading and you should be fine. I'm sure there working on this bug, I hope they fix it soon.

share|improve this answer
    
Has this bug been reported? If not, it should be. –  Eliah Kagan Aug 4 '12 at 21:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.