Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

my Internet connection is 10baseT-HD, in order to surfing the network, I have to type the command "mii-tool -F 10baseT-HD" every booting. How can I make it auto-setting?

share|improve this question
    
which version of ubuntu and what desktop? Do you want to run this on login or when the machine is booting? Does mii-tool ask for an administrator password to run or does it run with the credentials of the user logged on. –  fossfreedom Dec 24 '11 at 7:25
    
um, ubuntu 11.10, unity desktop. and I just want it run when the pc is booting. Running the mii-tool must need the root permission; otherwise, it displays "no MII interfaces found". –  David Dent Dec 24 '11 at 11:13
    
I dont have any experience with mii-tool - however this link looks promising. Let us know what you find out: mouweb.com/2011/02/28/set-speed-and-duplexing-on-ubuntu-debian –  fossfreedom Dec 24 '11 at 12:13

2 Answers 2

Have you tried the following:

  1. Go To System Settings
  2. Select Network under Hardware
  3. Select configure on your connection
  4. Select IPv4 Settings tab
  5. Ensure Method is set to Automatic (DHCP)
  6. Select Save
  7. Select IPv6 Settings tab
  8. Ensure Method is set to Automatic
  9. Select Save

I would suggest restarting your system...hopefully this will automatically detect and connect your Internet! Good Luck!

share|improve this answer
    
all of your suggestions were done, but it doesn't work better at all... –  David Dent Dec 24 '11 at 11:16
up vote 2 down vote accepted

Add mii-tool -F 10baseT-HD to /etc/rc.local (before the exit 0) and then save it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.