Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I boot my laptop into Ubuntu 10.10, the wireless won't automatically connect; it is configured, and I can get a connection using "Connect to Hidden Wireless Network..." and selecting the name from the drop-down - however, the first time (per boot) I do this, it asks me to elevate myself. The connection works if I then surrender the elevated privilege. The connection is set as available to all users, and to connect automatically.

What I would like is that it silently and automatically connect to the wireless. How can I do that?

share|improve this question
1  
First I'd recommend not to use hidden network settings, because you'll have nothing but trouble from it (I am telling you this from my own personal experience). It is not a security feature, in fact, if you google it a bit, you'll discover that your network can actually be less secure with hidden SSID. It may also be the cause you need to elevate.. See brighthub.com/computing/smb-security/articles/1211.aspx –  dr Hannibal Lecter Oct 23 '10 at 10:42
    
@drhannibal I wish you'd post that as an answer rather than a comment. It is certainly helpful, and it may turn out to be the correct answer. –  Marc Gravell Oct 23 '10 at 11:11
    
there we go :) –  dr Hannibal Lecter Oct 23 '10 at 12:36
add comment

3 Answers

up vote 1 down vote accepted

I'd recommend not to use hidden network settings, because you'll have nothing but trouble from it (I am telling you this from my own personal experience).

It is not a security feature, in fact, if you google it a bit, you'll discover that your network can actually be less secure with hidden SSID. It may also be the cause you need to elevate..

See http://brighthub.com/computing/smb-security/articles/1211.aspx

share|improve this answer
    
Thanks; I'll give that a go and report back. Either way it sound like I shouldn't hide the SSID, regardless of whether it helps ubuntu :) –  Marc Gravell Oct 23 '10 at 17:19
    
All working fine now, and I'm content that I'm no less secure. –  Marc Gravell Oct 24 '10 at 8:43
    
Glad to hear that! –  dr Hannibal Lecter Oct 24 '10 at 10:26
    
If you're concerned with security, simply use WPA authentication instead of WEP. –  Oxwivi Feb 21 '11 at 11:53
    
I don't think, that a hint about the security risks is an answer to the question above! There are some cases in which the user has no privileges to change the network itself. In my case the wifi of my university has a hidden SSID and I have to bother with it. So a real answer how one can connect to a hidden wifi would be really helpful. My android tablet connects without problems, the windows pcs of the other students are connecting right after the user logged in, but for every single linux pc we have, we have to connect to that network manually, every time we sign in. –  NobbZ Oct 30 '13 at 15:35
add comment

You can set the keystore password to blank, therefore you will not be asked for a password anymore (I mean the keystore password, not your account password, obviously).

share|improve this answer
    
That sounds promising - but where can I find the keystore settings? My previous ubuntu usage has been in a VM, so I'm not familiar with many of the network settings (since the VM host took care of it...) –  Marc Gravell Oct 23 '10 at 9:32
    
@Marc System->Preferences->Passwords and Encryption Keys –  Douglas Leeder Oct 23 '10 at 17:22
    
-1: why would you want to lessen security on all keys and passwords in the keystone? :P –  Blacklight Shining Oct 26 '12 at 0:15
add comment

Take a look at this post, it can help you to solve your problem. Easy way to auto connect to a hidden wireless network in Linux/Ubuntu

share|improve this answer
1  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Marco Ceppi Dec 21 '11 at 13:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.